AutoRemote Join > IFTTT > EvenGhost push sending issue

Discussion in 'AutoApps' started by Karmalakas, Feb 26, 2020.

  1. Karmalakas

    Karmalakas New Member

    Joined:
    Jun 25, 2018
    Messages:
    4
    Likes Received:
    0
    Hi,

    I just reinstalled Windows 10 fresh and can't get EG to recieve message from IFTTT when I use Google Assistant on phone. I didn't have Chrome extension installed previously and managed to get it working, but now - can't find out what's the issue.

    I can send messages from phone to EG and back. I get response on GAssist as defined in my IFTTT applet. It just seems I need correct device ID to define in URL on IFTTT:
    https://joinjoaomgcd.appspot.com/_ah/api/messaging/v1/sendPush?text=MY_TEXT&deviceId=<...>

    If I change ID to Chrome's ID, then I get push on Chrome, but I used to get it straight on EG. What I might be missing?

    Thank you
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,421
    Likes Received:
    792
    You need to push it to Chrome and then enable the option there to redirect to EG :)

    upload_2020-3-6_13-19-3.png
     
  3. Karmalakas

    Karmalakas New Member

    Joined:
    Jun 25, 2018
    Messages:
    4
    Likes Received:
    0
    But I can send messages from phone to EG. It's just I can't figure out how to do it from IFTTT to EG. Or there's no way to do that without redirect? Will I be able to get pushes to Chrome if I redirect them all to EG? I have only a couple of specific cases I want to send to EG. And where do I find EG port?

    Oohh.... so many questions :D Sorry, but I'm confused :)
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,421
    Likes Received:
    792
    The only other way would be to expose your public IP to the world and have EG listen on that IP... I think the redirect option is safer and more reliable :)

    • Pushes to Chrome will still be processed by chrome but will also reach EG
    • You can check the port in the EG AutoRemote plugin's settings. It's usually 1818 but you can change it there if you want.
     
  5. Karmalakas

    Karmalakas New Member

    Joined:
    Jun 25, 2018
    Messages:
    4
    Likes Received:
    0
    Oh, I see
    Added a port and that was enough
    Thanks for explaining :)
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,421
    Likes Received:
    792
    No problem!
     

Share This Page