AutoRemote [Linux] Autoremote behind NAT

Discussion in 'AutoApps' started by Ivarson, Sep 13, 2015.

  1. Ivarson

    Ivarson New Member

    Joined:
    Mar 16, 2015
    Messages:
    4
    Likes Received:
    1
    I've got a RPi 2, which has a 3G-modem for mobility.
    I'm able to register my RPi and view external and internal IP as seen in Autoremote, but i can't send any message (connection refused).

    Sending and receiving data (linux=:= response) works fine on wired/wifi at home (phone and RPI on same network).

    Is this supposed to work or would i be forced to setup portforwarding for a NAT-scenario to work?
     
  2. Ivarson

    Ivarson New Member

    Joined:
    Mar 16, 2015
    Messages:
    4
    Likes Received:
    1
    Im looking into setting up reverse tunnels with autossh, but a autoremote-enabled RPi would be so much cooler!
     
  3. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    I could only get it to work with port forwarding myself :) Sorry for the trouble
     
  4. invisible00420

    invisible00420 New Member

    Joined:
    Mar 30, 2017
    Messages:
    1
    Likes Received:
    0
    I am facing a similar problem. I know how to setup a reverse ssh tunnel, but can anyone tell me how to then use reverse tunneling to send commands to my device behind NAT using autoremote.
     

Share This Page