No profile actually kicks in until I turn my tablet's screen on

Discussion in 'Tasker' started by Jaroslav Truchly, Apr 18, 2017.

?

Any suggestion what could be wrong? no profiles actually kick in until I turn my tablet's screen on

  1. help

    0 vote(s)
    0.0%
  2. help

    0 vote(s)
    0.0%
  1. Jaroslav Truchly

    Jaroslav Truchly New Member

    Joined:
    Mar 25, 2017
    Messages:
    1
    Likes Received:
    0
    Hi guys
    For the last couple of weeks I have installed nearly all of autoapp-plugins. They are great.
    Unfortunately I am experiencing one constant problem. It is probably not related to your plugins, but I hope you could help me to find the cause of the problem.
    I have a few profiles set up but none of them actually kick in until I turn my tablet's screen on.

    I set the system - speak to google home, via IFTTT - Maker command is send to tablet, via auto remote tasker gets the command,
    1. when display is on everything works great profiles get executed
    2. when display is off the application starts, but does not load fully until the display is on.

    When I turn on the display the profile gets executed.

    For instance.
    I have a profile where I get a button pressed by the autoimput plugin.
    The application gets started but get stuck when I turn on the display via the power button the profile gets executed, the button gets pressed.

    Sometimes everything runs well even with a display off. But each time after a longer period of time the profiles get stuck.
    I have to turn on the display and than it works for some time.

    Android 4.4.2
    Samsung tab 10.1 GT N8000

    I did all I found on the internet.
    Reinstalled tasker.
    Changed settings in the monitor settings in tasker.
    Changed profiles
    But slowly running out of option what this annoying problem may be causing

    Any suggestion will be greattely appreciated

    Thank you for your time
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799
    Is your tablet maybe rooted? Do you maybe have some third party app that's blocking Tasker or the AutoApps in the background?

    Glad you're enjoying the apps! :)
     
  3. Old Bear

    Old Bear Member

    Joined:
    Mar 15, 2015
    Messages:
    36
    Likes Received:
    2
    Have you taken Tasker out of Battery Optimization (Doze)? Could be Tasker is going to sleep when the display goes off.
     
  4. Claudio GUimaraes

    Claudio GUimaraes New Member

    Joined:
    Jan 6, 2018
    Messages:
    9
    Likes Received:
    0

    Hi,

    I'm going through exactly the same problem.

    My cell phone is rooted. It was going well, suddenly this problem started happening.

    I have Google Home Mini and i'm listening autovoice command being triggering but the action not happening until i turn on my screen
     
  5. surge919

    surge919 New Member

    Joined:
    Aug 6, 2016
    Messages:
    14
    Likes Received:
    0
    I have the same problem.

    I have a profile that detects my car's bluetooth.
    On detection, it turns up the Bluetooth volume, starts up my music app and hits play.

    Nothing happens until I turn on the screen, once I do, the app opens and starts playing.

    I have turned off battery optimizations.

    thanks
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799
    Sorry, every device is different :( It's really hard to figure out what it could be on all devices...
     
  7. surge919

    surge919 New Member

    Joined:
    Aug 6, 2016
    Messages:
    14
    Likes Received:
    0
    Is there anything I can provide to help you figure this out? logs, more details etc?
    Tasker is excellent but this one item drives me nuts.

    thanks
     
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799
    Maybe check Tasker's logs after you enable Run Logs? Maybe some relevant info there...
     
  9. e1miran

    e1miran New Member

    Joined:
    May 18, 2017
    Messages:
    6
    Likes Received:
    0
    I'm having a similar issue on a Nexus 9 tablet, which I'm trying to use solely for Tasker/AutoVoice in order to serve processes for use with GH and GA on other devices (turn on my IoT enabled TV, turn on my DirecTV box and change channels, etc).

    Here an example:
    I have a process that uses Tasker to scrape and parse text from a website at 2:45AM. Then the following day I can request the data be read to me using GH or GA on another device by asking AutoVoice. The 2:45AM profile processed correctly overnight. But in the morning, when I request AutoVoice to read it to me, it returns the response from the Default Fallback Intent. I tried 5 times with the same result.

    So, I go over to the tablet (which autolock is disabled) and wake-up the display and check the Tasker log. The log shows no action since the completion of the 2:45AM process. The profile I requested using the AutoVoice command was not activated at all. So then, with the display on, I ask AutoVoice from a separate device again to read me the data, and now it works. Two hours later I initiate the same request again using AutoVoice and a separate device and it works again even with the display off.

    I can only assume that Tasker is becoming inactive after some time with the screen off, but that still doesn't explain how the 2:45AM process manages to run, unless the issue has somehow to do only with not recognizing the AutoVoice action after a time of inactivity.

    Are there any steps I can take to prevent this? It's a pretty much vanilla Nexus 9 recently restored to factory, never been rooted. Battery optimization is disabled and not much else is running except for Tasker. Any recommended settings in the Tasker monitoring preferences? Sorry for the long post, hopefully the detail helps. Thanks.
     
  10. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799
  11. sviudes

    sviudes New Member

    Joined:
    Mar 21, 2018
    Messages:
    7
    Likes Received:
    0
    I'm having the same issue. I run Tasker tasks from AutoWear, but it only works when my Pixel 2 XL screen is on. I'm a Tasker beta tester, and I have latest beta version, but it still doesn't work.
     
  12. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799
    Just to confirm, did you put both AutoWear and Tasker in the non-dozed apps list?
     
  13. sviudes

    sviudes New Member

    Joined:
    Mar 21, 2018
    Messages:
    7
    Likes Received:
    0
    I have Tasker. I have just added AutoWear and AutoApps. I'll test it and I'll post the result. Thanks.
     
  14. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799
    Thanks.
     
  15. sviudes

    sviudes New Member

    Joined:
    Mar 21, 2018
    Messages:
    7
    Likes Received:
    0
    I've just tested it, and it doesn't work while screen is off. Tasker, AutoWear and AutoApps are not optimized by Doze :(
     
  16. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799
    Hmm, ok, I'm working on an update for Tasker that could fix this actually. Hope you can hold on just a little while longer. Thanks in advance.
     
  17. sviudes

    sviudes New Member

    Joined:
    Mar 21, 2018
    Messages:
    7
    Likes Received:
    0
    Thank you. Let me know if I can help in any way. I develop Android apps too.
     
  18. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    799
    Oh cool! :D Do you already have Tasker integration in your apps? Would it fit? I'm making it very easy for other devs to create plugins for Tasker now and wanted someone to give it a try :)
     
  19. sviudes

    sviudes New Member

    Joined:
    Mar 21, 2018
    Messages:
    7
    Likes Received:
    0
    Not yet. I mainly develop games and entertainment apps.

    I'll take a look at the docs (tasker.joaoapps.com/developers.html) to see what can I do :)
     
  20. sviudes

    sviudes New Member

    Joined:
    Mar 21, 2018
    Messages:
    7
    Likes Received:
    0
    I've been reading logcat, and I realized that tasker task is actually running, but it's failing. I'm using this plugin to send an HTTP POST request, and I'm getting a timeout error when mobile device screen is off. Last plugin update was on 2015, so it may be the reason it's not working.

    The good news is that is not Tasker fault :) I'm trying to create a task to send an HTTP POST (without any plugin), selecting Net -> HTTP Post in Tasker, but it seems I cannot add headers to the request. Is there any way to send an HTTP Post with headers with Tasker?

    EDIT: I added REST plugin to Doze whitelist, but it still doesn't work sometimes. Would be great to add custom headers to HTTP Post task in Tasker.
     
    Last edited: Mar 23, 2018

Share This Page