Solved NodeRed Device deleted, not able to get it back

Discussion in 'Join' started by ebenbre, Feb 13, 2019.

  1. ebenbre

    ebenbre New Member

    Joined:
    Feb 13, 2019
    Messages:
    4
    Likes Received:
    0
    Hi,

    I deleted my NodeRed created device in the Join App, and tried everything I could think of to get it back:
    - changed API in NodeRed
    - removed and reinstalled the join contrib
    - reinstalled NodeRed

    I can send from NodeRed to my other devices, but since NodeRed is no longer visible as device I can't send to it.

    Would be really happy if someone could solve this.

    Br,
    Benjamin
     
    Last edited: Feb 13, 2019
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,729
    Likes Received:
    739
    Can you please post the logs of when you first start node-red so I can see what Join says? Thanks
     
  3. ebenbre

    ebenbre New Member

    Joined:
    Feb 13, 2019
    Messages:
    4
    Likes Received:
    0
    Hi,

    thanks for the reply.
    Here is the relevant part form the log:
    Feb 14 21:14:13 meineCCU daemon.debug node-red[6619]: Module: node-red-contrib-join-joaoapps 1.1.1
    Feb 14 21:14:13 meineCCU daemon.debug node-red[6619]: /usr/local/addons/redmatic/var/node_modules/node-red-contrib-join-joaoapps
    Feb 14 21:14:18 meineCCU daemon.info node-red[6619]: [join-server:TinkerNode] Starting server on port 1820...
    Feb 14 21:14:19 meineCCU daemon.info node-red[6619]: [join-server:TinkerNode] Not registering device because IPs are the same.

    But I have no clue which IPs are meant here.
    As mentioned it worked with the same setup till I deleted the Device in the Join App.

    Thanks,
    Best regards,
    Benjamin
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,729
    Likes Received:
    739
    If you delete Join's data in Node-RED it should register again. It means that your PC's IPs are the same since it last registered, so it doesn't register again.

    Are you able to delete Join's data?
     
  5. ebenbre

    ebenbre New Member

    Joined:
    Feb 13, 2019
    Messages:
    4
    Likes Received:
    0
    I am not sure where that is stored, that is why I tried to to remove and reinstall join in node red. But that did not delete the data then.

    If you can point me towards the location I can delete it.

    Else I understand I could change the IP as well, right?

    Thank a lot for the great support!
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,729
    Likes Received:
    739
    Yes, you could also try changing the IP :) I'll try to find out where it's stored, thanks!
     
    ebenbre likes this.
  7. ebenbre

    ebenbre New Member

    Joined:
    Feb 13, 2019
    Messages:
    4
    Likes Received:
    0
    Changing the IP did work.
    But would still be cool to know if there is another way.

    Thanks anyways, now my setup is working again.
     
  8. Turbs

    Turbs New Member

    Joined:
    Apr 11, 2019
    Messages:
    1
    Likes Received:
    0
    I have the same issue I'm afraid and I'm unable to reset my IP address as I've too many devices pointing to it. It's my mqtt server as well as node-red.
    Is anyone aware of where the Join data is stored so I can delete it and try to get my device back please?

    EDIT: Sorted. I had to uninstall the Join node from the pallet manager and reboot node-red.
    That cleared all saved data. Reinstall and re-config made the node-red device show up in Join again. :)
     
    Last edited: Apr 11, 2019
: NodeRed, Join, device

Share This Page