AutoRemote Notification sound

Discussion in 'AutoApps' started by Brad, Mar 26, 2015.

  1. Brad

    Brad New Member

    Joined:
    Mar 25, 2015
    Messages:
    3
    Likes Received:
    0
    I've set all the notification sound settings to None, but AutoRemote still makes a sound when a notification arrives. Is this a bug or am I overlooking a setting.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Sorry. I can't reproduce that. What notification are you sending? What fields are you setting?
     
  3. Brad

    Brad New Member

    Joined:
    Mar 25, 2015
    Messages:
    3
    Likes Received:
    0
    Preferences -> Alerts -> Notifications
    And then I set Default Sound and every Sound 1 - 10 option to None

    A sample of what is being sent that causes this is:
    https://autoremotejoaomgcd.appspot.com/sendnotification?key=mykey&title=title&text=text

    The sound I get is not set anywhere else on my phone, as far as I can tell, and I've never heard that particular sound until after I installed and setup AutoRemote.

    If I change the Default Sound setting (in AutoRemote), then I get the sound I choose. If I set the Default Sound setting back to None, then I get this unspecified sound that sounds sort of like a single strum on a zither.
     
    Last edited: Mar 27, 2015
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Maybe there's another app on your phone that's generating the sound? Do you have any other apps that are able to intercept your notifications?
     
  5. Brad

    Brad New Member

    Joined:
    Mar 25, 2015
    Messages:
    3
    Likes Received:
    0
    Here is what I've discovered that leads me to believe it's in AutoRemote. I have the AutoRemote Default sound set to None.

    If I use the URL:
    https://autoremotejoaomgcd.appspot.com/sendnotification?key=mykey&sound=0&title=title&text=text
    Then I get the notification and no sound is generated. If I use the same URL, but leave out the sound parameter, then I get the previously indicated sound. This leads me to believe that when the sound parameter is missing from the URL, then AutoRemote is failing to lookup the Default sound properly.

    At this point, I've found that specifying sound=0 is a workaround.
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    I just tried doing exactly that and I couldn't reproduce it. :( Hate it when this happens... This just leads me to believe it's something device specific... Glad you found a work around for now though. Thanks for your feedback.
     
: notification

Share This Page