AutoWear 'null' in Command Match

Discussion in 'AutoApps' started by DarthStark, Jun 12, 2018.

  1. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
    To make sure Tasker and the AutoApps run in the foreground:
    - make sure Tasker is enabled
    - enable foreground notification in Tasker settings
    - enable the "Use reliable alarms" option
    - Disable battery optimization for the apps
    - Make sure the Android Settings -> Apps -> Tasker -> Battery -> Background activity option is enabled (this setting may be somewhere else on different OEMs, but it's a very important setting that might be disabled by default on some devices)
     
  2. DarthStark

    DarthStark New Member

    Joined:
    Apr 19, 2018
    Messages:
    16
    Likes Received:
    0
    I think I tried all that, but I'll recheck.
     
  3. DarthStark

    DarthStark New Member

    Joined:
    Apr 19, 2018
    Messages:
    16
    Likes Received:
    0
    I tried all that, and also tried running the commands with Tasker open in front of me. It's still unreliable...
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
    Ok, I might have something.
    Can you please export your profile's description (not xml) so I can take a look? Long-click the profile in Tasker->export description Thanks in advance
     
  5. DarthStark

    DarthStark New Member

    Joined:
    Apr 19, 2018
    Messages:
    16
    Likes Received:
    0
    Ok! I had to name the profile in order to export it.

    Profile: TimeSetter (36)
    Event: AutoWear Command [ Configuration:Command Filter: ^timeP.*
    Regex: true ]
    Enter: timeP Processor (41)
    Run Both Together, Stay Awake
    A1: AutoWear App [ Configuration:Execute Now: true
    Trigger Event: true
    Haptic Feedback: true
    Name: App
    AutoWear Elements: Hide
    AutoWear Element Id: TimePScreen Timeout (Seconds):60 ]
    A2: Flash [ Text:%awmessage Long:Off ]
    A3: Perform Task [ Name:timeP Executor Priority:%priority Parameter 1 (%par1):%awmessage Parameter 2 (%par2): Return Value Variable: Stop:Off ] If [ %awmessage neq timePcancel ]
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
    Does it work if you change the event to an AutoApps event with the same filter instead of an AutoWear event?
     
  7. DarthStark

    DarthStark New Member

    Joined:
    Apr 19, 2018
    Messages:
    16
    Likes Received:
    0
    Ok, I created a new profile. It's working so far, I'll test for the next few days.
     
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
  9. DarthStark

    DarthStark New Member

    Joined:
    Apr 19, 2018
    Messages:
    16
    Likes Received:
    0
    Hi,

    It seems more reliable (only one message got lost, and I can't rule out watch-to-phone issues). But it sometimes takes up to 5 minutes to process the message. I have Oreo's battery optimization turned off for all apps involved (autowear, autoapps and tasker). Any suggestions?

    And just out of curiosity (i'm a programmer as well), what's different between the AutoApps and AutoWear tasker profile plugin?
     
  10. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
    Ok, what about with this version of AutoApps?

    In AutoApps I made some customizations that I haven't applied to AutoWear, so that's why it probably works better :)
     
  11. Danial Wacker

    Danial Wacker New Member

    Joined:
    Jul 21, 2018
    Messages:
    3
    Likes Received:
    0
    Hello There!
    I also have problems with the connection to tasker.
    I have an Huawei watch 2 (LEO-BX9) with wear os 2.0 and a Honor 9 with Oreo 8.0.0.366(C432).
    I tried all the things which is written here in the post. When the phone is on, everything works fine. But when the phone is on Standby, the Profile from the Tasker didn`t start.
    I tried it also with the new AutoApps version from you which i downloaded and set it in the Tasker Profile instad of Autowear.
    As you can see on the pictures, the command comes from the watch to the AutoWear-App. With phone on it works. with phone Standby the command doesn´t come to the tasker. (Also see the message in the bottom on the AutoWear app -"The callable returned a null value")

    Hopefully there is a solution. Cause now i allways have to turn on the phone before i can use the AutoWear for my Smarthome.

    Thank you very much.
     

    Attached Files:

  12. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
    - On Huawei devices disable Powergenie which stops apps from running in the background. Try going to Settings -> Battery, then tapping on the gear in the upper right corner. Disable "Close excessively power-intensive apps". Or use ADB:
    To disable powergenie use:
    adb shell pm disable-user com.huawei.powergenie

    To enable powergenie:
    adb shell pm enable com.huawei.powergenie

    Hope this helps!
     
  13. Danial Wacker

    Danial Wacker New Member

    Joined:
    Jul 21, 2018
    Messages:
    3
    Likes Received:
    0
    Hello!
    Thanks for the quick support.
    The steps doesn´t work. I dont have "Close excessively power-intensive apps" at Settings / Battery / gear right Corner on EMUI 8.0.0 -> see photo.
    with shell i have a problem with the user. I think i have to be a SU to do this. (Error-message see photo)
    But i don´t really want to root my phone when it´s not absolutely necesarry.
    Probebly there is an other solution? Hopefully!

    Thank you very much!
     

    Attached Files:

  14. Danial Wacker

    Danial Wacker New Member

    Joined:
    Jul 21, 2018
    Messages:
    3
    Likes Received:
    0
    Hello there!

    Any other ideas to solve the problem? I still probably have the problems.
    Thank you
     
: AutoWear

Share This Page