Persistent Memory While Developing Tasks

Discussion in 'Tasker' started by pixelpop, Aug 4, 2017.

  1. pixelpop

    pixelpop New Member

    Jul 28, 2017
    Likes Received:
    I seem to have an issue where tasks that I am developing are becoming persistent in memory. The result is that the task does not run correctly until the phone is restarted. For instance, I create several steps within a task that include decision logic, events and actions, and then run it. If the task does not run correctly, I will remove or change one or more of these steps. When I run the task again, it is still not running correctly. However, if I restart my phone the tasks now runs as intended (and as described within the task). It appears that the task is becoming persistent in memory and not picking the changes made during development. I am using a Galaxy S8 with all system and app updates.

    Has anyone experienced similar behavior?
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Feb 3, 2015
    Likes Received:
    You usually need to exit Tasker for the new versions to come into effect. Are you doing that?

Share This Page