AutoRemote Personal Key is 'null'

Discussion in 'AutoApps' started by C19H28O2, Apr 28, 2015.

  1. C19H28O2

    C19H28O2 New Member

    Apr 28, 2015
    Likes Received:
    My phones personal key is 'null' and I don't know how I can fix it. I'm able to send messages from my phone to event ghost but not vice versa.

    AutoRemotes log says (in the Google Authentication tab):
    'There was an IO error: NetworkError: NetworkError'

    What I have tried so far
    - 'Repair AutoRemote Url' in settings
    - Restore backup
    - Reinstall AutoRemote

    No matter what I do, I'm always ending with the same URL including a personal key of 'null'.

    Could it be cause I'm running cm12.1?


    One night and a headache later I fixed it by myself.

    My original personal URL (which has a key) was still in the chrome plugin. I manually created a backup of it, put it on dropbox and restored it on my phone. That was the point where the personal key = null error disappeared. But I still wasn't able to send messages to my phone. Surprisingly, only over wifi, sending over mobile data worked....

    So after reading the internet and looking over my settings I noticed that in 'Plugin: AutoRemote' (EventGhost) I had left the devices local IP fields emtpy, which wasn't a problem before. But since I filled these fields + sending my device info from tasker right after activating the wifi service, I'm able to send messages to my phone again.

    So the only error left is the one in the 'Google Authentication' tab, but i was able to narrow it down. It is definetly not AutoRemotes fault. I can't sync my google account correctly and some of my google apps seem to have some problems too, I think it came from upgrading my ROM + importing some backups. But i think it won't be a big deal fixing it, even if it would be necessary to wipe my phone and flash the ROM again.
    Last edited: Apr 30, 2015
: Personal, key

Share This Page