AutoInput Problems when trying to toggle High touch sensitivity

Discussion in 'AutoApps' started by mkkyah, Aug 29, 2015.

  1. mkkyah

    mkkyah Member

    Joined:
    Aug 29, 2015
    Messages:
    31
    Likes Received:
    1
    Hi,
    I have bought Autoinput today and try to learn to use it.
    My main goal is to toggle "High touch sensitivity"(glove mode) on my Z3c running CM12.1.
    I may be trying a foolishly wrong path to do it, but my list of task are like this:
    1--Tasker Launch app "settings"
    2--Autoinput click "Language & Input"
    3--Autoinput click "High Touch Sensitivity"

    1 and 2 are working well as expected, but 3 is not working unless I manually scroll down on that page before timeout. I think this happens with all sub pages of settings, not related to only settings I have chosen. I also couldn't create an automated scroll down.
    Is this a bug or am I missing something (probably)?
    Even if there is a better way to achieve this (please feel free to enlighten a newbee), I wish to know what's wrong here.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    AutoInput can only click what's currently showing on the screen so you won't be able to click if something's not on the screen. Have you tried the "scroll forward" action in the "AutoInput Action" action in Tasker?
     
  3. mkkyah

    mkkyah Member

    Joined:
    Aug 29, 2015
    Messages:
    31
    Likes Received:
    1
    "Language & Input" is also NOT on the screen when you launch "settings"; but AutoInput easily clicks on that with all type options.

    I couldn't make "scroll forward" work there, too.
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    Maybe it's just offscreen and AutoInput is still able to catch it? You need to use scroll forward on an on-screen item, did you do that?
     
  5. mkkyah

    mkkyah Member

    Joined:
    Aug 29, 2015
    Messages:
    31
    Likes Received:
    1
    Can I ask for more detail about what you mean?
    I did choose action "scroll forward" in AutoInput Action/Action, nothing happened. Do I need choose field type, nearby text with that?
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    When you scroll forward you still need to say on which item you want to do the action.
    For example, if you scroll forward with your finger, you'll put your finger on an on-screen item, right? :) Here the same thing applies. You need to tell AutoInput where to put it's "finger" when you scroll forward.
    So just use the easy setup and configure scrolling forward with an on-screen item that's in a scrollable list.
    Hope this helps!
     
  7. mkkyah

    mkkyah Member

    Joined:
    Aug 29, 2015
    Messages:
    31
    Likes Received:
    1
    Yes, Yes, Yes!
    It's now toggling glove mode.

    I still don't understand how "Language & Input" can be offscreen and work. That submenu is almost at the end of that page and it's working easily.
    BTW. Is there another direct way to toggle glove mode with tasker in the AutoApps+SecureSettings world which I'm missing?
    Thanks for the apps and thanks for the support.
     
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,450
    Likes Received:
    718
    I'm not aware if there's any other way, sorry!

    Technically speaking, AutoInput can click anything that the screen has rendered, and maybe because of optimization purposes on the screen you're on, "Language & Input" has already been rendered even while being off-screen :)

    Glad it works now!
     

Share This Page