AutoVoice Receiving Autovoice errors from Alexa today

Discussion in 'AutoApps' started by GeneMar, Oct 25, 2018.

  1. GeneMar

    GeneMar New Member

    Joined:
    Oct 25, 2018
    Messages:
    7
    Likes Received:
    0
    Good day.

    I am having a comedy of errors today. Earlier today, I was playing around with this suggestion to ensure a spoken number arrives in Tasker as a number. My resulting command:
    > credenza (?<duration>[0-9]{1,2})​
    Worked great with Credenza 2, but when I said Credenza 1, I found this in the AV Log:

    Send the developer an email with this error: Error in {min,max} interval near index 28
    ^credenza (?<amount>[0-9]{1$

    ^​

    I’m not particularly worried about that, I can research the Regex issue later, however, now, anything spoken to Alexa returns this message, too. (I couldn't attach an mp3, so please listen from my Dropbox.

    To make matters worse, and I assume this is an effect of the above, I accidentally deleted an AutoVoice Smarthome device in the Alexa application. Now, when I search for devices and pick that AutoVoice Smarthome device, when I click the blue Next button, the Alexa App is dead; need to force close it.

    I removed my AV devices, cleaned up both apps, even rebooted the phone. No joy.

    So, given no hits on this topic, is this something associated with my account?

    Appreciate your time with any suggestion to get me running again.
    Heaven forbid I have to get up and turn on a light! ;-)

    Gene
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
    Did you use that regex in one of the commands in AutoVoice -> Personal Assistant -> Commands? Those don't support regex :) That might be your issue...
     
  3. GeneMar

    GeneMar New Member

    Joined:
    Oct 25, 2018
    Messages:
    7
    Likes Received:
    0
    I am interpreting AutoVoice -> Personal Assistant to mean asking Ok Google to Ask AutoVoice <that command>. If that is the case, no, I haven't. But then again, I'm not worried about this Regex command. As noted, I can no longer even ask Alexa "Ask Autovoice to say Hello".
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
    Sorry, I meant opening the AutoVoice app and going to Personal Assistant -> Commands
     
  5. GeneMar

    GeneMar New Member

    Joined:
    Oct 25, 2018
    Messages:
    7
    Likes Received:
    0
    Thank you, I was never clear on what term meant!.
    That did fix the issue. When I ask Alexa "Ask Autovoice to say Hello", it now responds with Command Sent (though I have nothing to service that ask.)
    My Alexa app will still hang trying to Control A Device using my AV device. Will now delete all those and take it from the top again.
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
    Glad you got it! :)
     
  7. GeneMar

    GeneMar New Member

    Joined:
    Oct 25, 2018
    Messages:
    7
    Likes Received:
    0
    Everything is ok, but even after creating my One AV Smarthome device, and Alexa discovering it, when I add it to a routine, and set the percentage for that AV Device, by Alex app freezes. It's always something...
     
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    805
    That I can't help with, sorry!
     
: autovoice

Share This Page