AutoWear simple bluetooth apk not working on watch

Discussion in 'AutoApps' started by mrizzard, Apr 29, 2020.

  1. mrizzard

    mrizzard New Member

    Joined:
    Jul 19, 2019
    Messages:
    2
    Likes Received:
    0
    Hey there
    I've tried searching all forums and can't find the solution or a replication of this issue.
    I've created a very simple APK to run as standalone on my watch, using Autowear Settings.
    It's meant to turn off the watch bluetooth, wait 20 seconds, then turn it back on.
    Finally got the APK loaded and installed in the watch (plus did the write permissions shell command just in case) and every time i click the app i created in the watch, it creates notifications saying it needs the required Autowear plugin to work (which of course is already on the watch along with all needed permissions checked - i've even tried uninstalling autowear but no joy) and nothing happens.
    In case this helps or means anything, when the app is pressed there's also a persistent notification on the watch saying No Active Profiles.
    Is this an easy fix?!
    I really need to get this to work because there's a bug where, unless the bluetooth on the watch is cycled each time it's connected to my phone, it loses the ability to answer phone calls on the watch and use the inbuilt speaker + mic.
    cheers
    James
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,480
    Likes Received:
    801
    Hhmm, how exactly did you create that APK?
     
: autowear

Share This Page