AutoWeb Spotify - Transfer Action

Discussion in 'AutoApps' started by Brian86, Nov 22, 2017.

  1. Brian86

    Brian86 New Member

    Joined:
    Jul 26, 2017
    Messages:
    9
    Likes Received:
    1
    Just wondering if anyone has gotten the spotify "Transfer user playback " action to work in the autoweb spotify api.

    Description: Transfer a User's Playback
    Endpoint: https://api.spotify.com/v1/me/player
    HTTP Method PUT
    OAuth: Required
    OAuth Scope: user-modify-playback-state
    PUT Body:
    Code (Text):
    {
      "device_ids": [
        "Id here"
      ]
    }
    This is what I get when I run the task.
    Code (Text):
    17.02.34/ActionArgBundle key: JoinOutputArray: replace <null> String value with null
    17.02.34/E FIRE PLUGIN: AutoWeb Web Service / com.twofortyfouram.locale.intent.action.FIRE_SETTING: 14 bundle keys
    17.02.34/E AutoWeb Web Service: plugin comp: com.joaomgcd.autoweb/com.joaomgcd.autoweb.broadcastreceiver.BroadcastReceiverFire
    17.02.34/E add wait type Plugin1 time 120
    17.02.34/E add wait type Plugin1 done
    17.02.34/E add wait task
    17.02.35/E Error: 317504052
    17.02.35/E {  "error" : {    "status" : 400,    "message" : "Malformed json"  }}
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    806
    Can you please try this in AutoWeb:
    - clear logs
    - enable system logs
    - do the action
    -export logs and paste them here

    Thanks!
     
  3. Brian86

    Brian86 New Member

    Joined:
    Jul 26, 2017
    Messages:
    9
    Likes Received:
    1
    Sent you pm
     
  4. Andrzej Belka

    Andrzej Belka New Member

    Joined:
    Mar 21, 2018
    Messages:
    5
    Likes Received:
    0
    Hi! I have the same issue. Did you manage to investigate it?
     
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    806
    Sorry, don't remember anymore :) Can you post the logs like I mentioned above?
     
  6. Andrzej Belka

    Andrzej Belka New Member

    Joined:
    Mar 21, 2018
    Messages:
    5
    Likes Received:
    0
    I've attached the log as I can't just paste it here.
     

    Attached Files:

  7. Andrzej Belka

    Andrzej Belka New Member

    Joined:
    Mar 21, 2018
    Messages:
    5
    Likes Received:
    0
    @joaomgcd any news ? I need this to properly start playing music with Alexa devices. The play/pause functionality does not activate the device you want to select so this is the only way I see to make it work...
     
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    806
    Hmm, weird there should be a response there. Did you really enable system logs?
     
  9. Andrzej Belka

    Andrzej Belka New Member

    Joined:
    Mar 21, 2018
    Messages:
    5
    Likes Received:
    0
    That is all I get from the logs. When I run it I got a popup with message:
    Error calling API Action
    Please try to correct you API action input or API configuration:
    { "error" : { "status" : 400, "message" : "Malformed json" }}

    That is all...
     
  10. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,477
    Likes Received:
    806
  11. Andrzej Belka

    Andrzej Belka New Member

    Joined:
    Mar 21, 2018
    Messages:
    5
    Likes Received:
    0
    Responded on priv with video. But it does work in the Spotify web console.
     
  12. ratelutz

    ratelutz New Member

    Joined:
    Apr 23, 2017
    Messages:
    12
    Likes Received:
    0
    have you found a solution?
     
: Spotify

Share This Page