AutoTools ssh timeout

Discussion in 'AutoApps' started by jjletho, Apr 9, 2018.

  1. jjletho

    jjletho New Member

    Apr 9, 2018
    Likes Received:
    I was an happy autotools user, I use the ssh feature with tasker to do some automation.
    Suddenly the plugin has started to not work properly: very often i encountered a timeout exception and only occasionally ssh connection are correctly established.

    I did a lot of test and i can be almost sure that i'm facing something which is not a real connection timeout. I tested with both wifi (with the server connected on the same subnet) and remote data connection with the same result. On the same phone and with exactly the same connectivity conditions i successfully connected to the server using a simple ssh terminal app. I checked that autotools is not "battery optimized", it has all the needed permissions and it is allowed to use data connection.
    I also tried to increment the timeout value, but i have the impression that it is ignored, timeout exception arises always about 30-60 seconds after i fire the connection. When thing goes well the connection is really quick, usually no more than 10 seconds)

    What else can i do?
    I'm on Android 7.1.1 (MIUI global

    Thank you very much
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Feb 3, 2015
    Likes Received:
    Can you please try the new Tasker and AutoTools betas? I fixed some issues regarding timeouts there :) Hope this helps.

Share This Page