AutoInput Swipe Gestures not working on Galaxy S9

Discussion in 'AutoApps' started by FelixII, Apr 29, 2018.

  1. FelixII

    FelixII New Member

    Joined:
    Apr 29, 2018
    Messages:
    4
    Likes Received:
    0
    Hi,

    I'm trying to set up a swipe gesture in Tasker with AutoInput. When I run my workflow, I receive the following error output:
    Code (Text):
    Error: 1129115643
    Couldn't perform gesture: null
    I have enabled accessibility access for both Tasker and AutoInput.

    My device is a Samsung Galaxy S9 SM-G960F on Android 8.0.0. I do not have root access nor any customizations on my device.

    I attach two screenshots of my Tasker configuration:
    screenshot.jpg screenshot-2.jpg

    Thanks for your help! Please let me know if you need additional information or any log files.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,338
    Likes Received:
    784
    Thanks for the report. Do you maybe have a space after the coordinates?
     
  3. FelixII

    FelixII New Member

    Joined:
    Apr 29, 2018
    Messages:
    4
    Likes Received:
    0
    No, I entered the coordinates without any spaces, neither in the middle nor at the end. My format is: <value1>,<value2>
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,338
    Likes Received:
    784
    Hmm, I just tried it myself on a Galaxy S9 and it worked correctly.. Are you sure the AutoInput accessibility service is enabled?
     
  5. FelixII

    FelixII New Member

    Joined:
    Apr 29, 2018
    Messages:
    4
    Likes Received:
    0
    Yes, here are my settings:
    Screenshot_20180504-201702_Settings.jpg Screenshot_20180504-202157_AutoInput.jpg
    If you need more information or want me to run some tests, please let me know. Thank you for your help!
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,338
    Likes Received:
    784
    Thank you. Does it help if you reboot?
     
  7. FelixII

    FelixII New Member

    Joined:
    Apr 29, 2018
    Messages:
    4
    Likes Received:
    0
    That helped indeed. I also tried a few reboots when I first reported this issue, so I'm not sure what has changed since then. Anyway, thank you! :) I'll let you know if I encounter this problem again.
     
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,338
    Likes Received:
    784
    Thank you! :)
     
  9. scotts

    scotts Member

    Joined:
    Jun 19, 2015
    Messages:
    138
    Likes Received:
    1
    Swipe gestures not working on my Note 8. I'm attempting to simulate a Microsoft Launcher gesture to open app drawer.

    Swipe Home (11)
    A1: Go Home [ Page:0 ]
    A2: Wait [ MS:0 Seconds:1 Minutes:0 Hours:0 Days:0 ]
    A3: AutoInput Gestures [ Configuration:Gesture Type: Swipe
    Manage Accessibility Service: Unchanged
    Start Point: 500,1500
    End Point: 500,1200
    Duration: 100 Timeout (Seconds):30 Continue Task After Error:On ]
    A4: Flash [ Text:%errmsg Long:Off ]

    Using Dev Options\Pointer location, I can see that the gesture is executed. However, no error and no result. AI accessibility permanently enabled, rebooted after creation of Task.


    Sent from my Note8
     
  10. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,338
    Likes Received:
    784
    Try setting a longer duration. Try 1000 for example.
     
  11. scotts

    scotts Member

    Joined:
    Jun 19, 2015
    Messages:
    138
    Likes Received:
    1
    Increasing Duration did get the Task to complete, but with error.

    When executed, it opens the home page/widgets settings, like when you touch and hold your finger on the Home screen. Then I receive the following error..."Couldn't perform gesture".
     

Share This Page