AutoNotification Text Filter Case Insensitive option not working

Discussion in 'AutoApps' started by asjasonsdp, Nov 1, 2019.

  1. asjasonsdp

    asjasonsdp New Member

    Joined:
    Nov 1, 2019
    Messages:
    6
    Likes Received:
    0
    Hello,

    I created an Autonotification profile in Tasker based on this guide.
    https://notenoughtech.com/tasker/tasker-plugin/autoapps/join/tasker-authentication-helper/

    I set the regex in the Text Filter to : (code|pin).*?\d{3,}

    I set the text filter to be case insensitive in the autonotification settings, but I realized I didn't test it with a capital letter until today when it didn't work.
    It works only if "code" or "pin" are lower case.
    I tried unchecking "Case Insensitive" in the Text Filter saving and then checking it again, but that didn't work.

    I worked around the issue by changing my regex to: (?i:code|pin).*?\d{3,}
    So now the regex specifies that the search is case insensitive.

    Is this an issue unique to my setup or is there a know issue with the autonotification -> Text Filter -> Case Insensitive setting?

    Thank you!
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Hi there. Does case insensitive work for you if you don't use a regex?
     
  3. asjasonsdp

    asjasonsdp New Member

    Joined:
    Nov 1, 2019
    Messages:
    6
    Likes Received:
    0
    Just tested. It does.
     
  4. virtual

    virtual New Member

    Joined:
    Jul 8, 2018
    Messages:
    19
    Likes Received:
    0
    Is this supposed to be fixed?
    Because I have the same problem with AutoNotification v4.1.4: Case Insensitive option doesn't work with Regex but works with normal text.
     
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    virtual likes this.
  6. virtual

    virtual New Member

    Joined:
    Jul 8, 2018
    Messages:
    19
    Likes Received:
    0
    Yes, the test version is working perfectly in my case!
    I also tried disabling Case Insensitive and it returned like before (i.e. case sensitive), so the switch is operating correctly now.

    Thank you!
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Cool! :)
     
    virtual likes this.

Share This Page