AutoInput Toggle "Ok Google" detection 1.0

Enable or disable "Ok Google" detection in the Google Settings with AutoInput

  1. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,710
    Likes Received:
    736
    joaomgcd submitted a new AutoApps project:

    Toggle "Ok Google" detection - Enable or disable "Ok Google" detection in the Google Settings with AutoInput

    Read more about this project...
     
    Last edited: Feb 11, 2015
  2. ckronengold

    ckronengold New Member

    Joined:
    Feb 11, 2015
    Messages:
    4
    Likes Received:
    0
    This is what my "OK Google Detection" screen looks like.
     

    Attached Files:

  3. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,710
    Likes Received:
    736
    Same for me :) Anything not working for you?
     
  4. ckronengold

    ckronengold New Member

    Joined:
    Feb 11, 2015
    Messages:
    4
    Likes Received:
    0
    Yeah, I'm unclear as to what I'm supposed to change in A5.

    If I change the value of the Text to "OFF", what text is it looking for? Its not as if there's an "Off" label or "On" label.

    Isn't it looking for that specific text string?
     
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,710
    Likes Received:
    736
    That text string is an accessibility string that exists behind the scenes.
    I posted the exact A5 examples you should be using.
    Try to use the A5 examples I posted and you'll see that it works :)
     
  6. ckronengold

    ckronengold New Member

    Joined:
    Feb 11, 2015
    Messages:
    4
    Likes Received:
    0
    Yes, they are working. Thanks very much.
    I dont mean to sound dense. I was just trying to understand what was going on, and was confused by your instructions to enter a text value that I didn't see.

    Thanks so much for the help. What is your preferred method of donating to support your efforts beyond buying the app?
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,710
    Likes Received:
    736
    Glad you got it working! :D
    If you want to donate I'd very much appreciate if you could donate some through PayPal. Check the right column of any page on http://joaoapps.com/ below the Recent Comments. You'll find the PayPal button there. :)
    Thanks again and have a good one!
     
  8. ckronengold

    ckronengold New Member

    Joined:
    Feb 11, 2015
    Messages:
    4
    Likes Received:
    0
    Thanks again for the help.
    Trying to learn Tasker, AutoInput and AutoVoice all at once is a bit more challenging than I expected.
     
  9. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,710
    Likes Received:
    736
    Thank you! Just got your donation! Appreciate it very much. :) Let me know if need any more help. Post about it in the forums if you like! ;)
     
  10. CarpeDiem

    CarpeDiem New Member

    Joined:
    Oct 21, 2015
    Messages:
    2
    Likes Received:
    0
    Hi,
    I'm TRYING Autoinput with this project and I had modified the commands to be compatible with the language I use with my phone (Italian). This shouldn’t cause any problems. However, in A2 (Search and Now becomes Ricerca and Now) I noticed that Tasker is stalling and eventually fails and stops the actions.
    On the other hand when A2 is fired and Google settings are showing up, if I scroll down, so that this menu item becomes visible, then Tasker is able to continue and terminates flawlessly its tasks.
    I can reproduce this 100% of the times.
    I tried as well to put a small wait time prior to A2, of no avail. It seems it has to do with the “visible menu items”?
    Am I missing something? Is there anything I could do to have the task execute by its own without any “manual” intervention?
    Thanks in advance for your suggestion.
     
  11. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,710
    Likes Received:
    736
    Hi, sorry for the late response. If you need to scroll down you can use the Scroll Forward action before the click :) Simply scroll forward on any existing on-screen element and it should work.

    Hope this helps!
     
  12. CarpeDiem

    CarpeDiem New Member

    Joined:
    Oct 21, 2015
    Messages:
    2
    Likes Received:
    0
    Thank you! Yes, it works like a charm, indeed. Very smart. I definitely need to learn more in the details how it works. Thanks again for your support.
     
  13. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,710
    Likes Received:
    736
    Great :) No problem.
     
  14. Fofaro

    Fofaro New Member

    Joined:
    Sep 13, 2017
    Messages:
    2
    Likes Received:
    0
    Hi,

    I'm kind of in the same situation as CarpeDiem : I'm trying out AutoInput and want to be able to activate Ok Google detection only when Waze is running. Problem is I can't get the Google settings to open... I thought the issue was because my phone is in French, so I went to edit the task in Tasker and looked for the correct app. I found "Paramètres de l'Assistant" (Assistant's Settings, with Google icon), but when using that alone in a test task I can only see the screen flicker very very rapidly (I can't even see if it opens the correct screen) and I'm back to Tasker. And there are no Google settings in the list (even when displaying "all")...

    For now I'm launching the Google app but it needs more clicks to get where I want (open Google > click the top-left menu > click settings > click settings under Google assistant section > click Phone under devices section > click "Ok Google" hotword detection > toggle "Ok Google" everywhere) and I'm hoping to make this quicker by opening directly the correct settings and getting rid of the red section. Plus there is actually a bug with the second click needed : it worked once but now it's either not clicking or clicking in the wrong spot and I need to click manually for the task to complete (AutoInput seems not to identify items from this menu at all, all the buttons have the same ID and position..?!). I've found this intent, it does launch the assistant but without the three-dots menu button and not in the same place than when using "Ok Google" or long home press, so there must be another way to emulate what both those activators do.

    Has the access to settings been modified/updated since the creation of this project ? If so could you tell me which intent I should put in to get the exact same result as "Ok Google" or long home press do ? Or a workaround ?
    I'm on a non-rooted Xperia Z5 Compact running Android 7.1.1.

    Thanks in advance for your help !
     
    Last edited: Sep 14, 2017
  15. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,710
    Likes Received:
    736
    Unfortunately you're right, the intent seems to have changed, sorry! I don't know how to call the assistant settings right now :(
     
  16. Fofaro

    Fofaro New Member

    Joined:
    Sep 13, 2017
    Messages:
    2
    Likes Received:
    0
    Thanks for your answer, I'll keep watching this thread for when you or someone else finds the correct intent.

    BTW I've solved the bug of my temporary fix by using another app with a button roughly in the same spot to get the correct coordinates, and setting a delay of 1sec before that click. That task is now working fine, I've also set it up to say "detection activated/deactivated" using a counter (if count is even/odd) because the alternatives proposed in the original project (toggle only if on or off) don't work for me: toggle on does the same thing as regular toggle and toggle off never does anything. That way I'll be able to use that counter to only enable or disable the detection (if count=even/odd).
     

Share This Page