Open Trying to send MMS through Join, consistently gives 'No Service' error

Discussion in 'Join' started by Mitalis, Jun 4, 2017.

  1. Mitalis

    Mitalis New Member

    Joined:
    Jun 4, 2017
    Messages:
    3
    Likes Received:
    0
    Like the title says, I attach the image, hit send, I'll see the spinning indicator and then it'll report 'No Service' on the Join Chrome app, as well as a toast popup message on the phone. The thing is, I do have service. And the method I've been having to do to get around this is to send the picture directly to my phone, and attach it via Messenger manually on my phone and send it.
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,732
    Likes Received:
    739
    Hi there.

    Are you maybe not using a "normal" way to send MMS from your phone? Maybe via Google Fi or some other non-standard method? Thanks in advance
     
  3. Mitalis

    Mitalis New Member

    Joined:
    Jun 4, 2017
    Messages:
    3
    Likes Received:
    0
    I don't use Google Fi, SMS/MMS are sent through my Verizon number, using Google Messaging app. I might also add at random the Join for Chrome plugin will stop working with SMS all together. Running a diagnostic on my phone shows tests 1-4 (Receive Push from Server - Compare GCM Keys) failing, then 5-8 (Send file to Google Drive - Send Notification to Chrome) passing. If I run the diagnostic a 2nd time, suddenly all tests pass.

    The Join SMS service is enabled on my phone. When I refreshed the SMS option in Join for Chrome plugin, now I'm only seeing text messages prior from Nov 2016, but it still won't send any composed from the plugin to my phone.
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,732
    Likes Received:
    739
    Please check that your phone doesn't have a third party app that's somehow limiting Google Play Services or Join's ability to work with the Google Cloud Messaging. Is your device rooted by any chance?

    That would be the reason why that would happen from time to time...
     
  5. Mitalis

    Mitalis New Member

    Joined:
    Jun 4, 2017
    Messages:
    3
    Likes Received:
    0
    I have the Google Pixel phone and it is not rooted. The only application that I know of that even interacts with the SMS/MMS DB is a backup/restore application I use on occasion. It does have an automatic backup scheduler service but that's always been disabled and the backups are run manually. As far as applications that I know of that interact w/ Google Play Services are the google apps themselves. Most of the 3rd party apps I have have pretty restricted permissions (with the exception of yours)
     
  6. SAMCRO

    SAMCRO New Member

    Joined:
    Jun 15, 2017
    Messages:
    2
    Likes Received:
    0
    Bump, i'm having the same issue, Verizon service for me too.
     
  7. menacestudio

    menacestudio New Member

    Joined:
    Oct 24, 2017
    Messages:
    1
    Likes Received:
    0
    I'm having the same issue. I have a Google Pixel (non rooted) and it fails to send pictures from the Chrome extension.
     
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,732
    Likes Received:
    739
    Hmm, I thought this was fixed actually. What happens when you try?
     
  9. Ringo1725

    Ringo1725 New Member

    Joined:
    Dec 23, 2017
    Messages:
    1
    Likes Received:
    0
    this is happening to me. I can't attach photos on my Mac Chrome Extension. Get the exact same message as everybody else 'no service' .... can send SMS messages, just not MMS. words yes, pics no. what's up? Thanks!
     
  10. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,732
    Likes Received:
    739
    Unfortunately that seems to happen for some people. I haven't been able to figure out why that is. For some people it's related to using Google Fi, for others it's unknown. I simply use the standard Android APIs to send MMS so whatever issue it is, it has something with a specific device configuration... Sorry, wish I could be of more help :(
     
  11. DrSuSE

    DrSuSE New Member

    Joined:
    Sep 11, 2019
    Messages:
    6
    Likes Received:
    0
    I know this is old, but since the issue still exists I thought that I would add something.

    For me, the error/issue only occurs when I try to send an image via MMS without any text along with it. If the message included text and an image... good. Image only, no good.
     
  12. Chris Brown

    Chris Brown New Member

    Joined:
    Apr 22, 2019
    Messages:
    2
    Likes Received:
    0
    I have the same issue.. sending an image through Chrome from desktop fails....error no service
     
  13. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,732
    Likes Received:
    739
    Does maybe selecting a SIM card (even if just re-selecting the only one available) in Join settings help?
     
  14. DrSuSE

    DrSuSE New Member

    Joined:
    Sep 11, 2019
    Messages:
    6
    Likes Received:
    0
    Doesn't seem to help for me. It has to be something related to the formation of the message, I think. What stands out for me is this:

    WORKS: Pic+text in single MMS
    DOES NOT WORK: Pic alone in MMS
     
  15. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,732
    Likes Received:
    739
    Thanks. I'll have to try and figure out why that is.
     
    DrSuSE likes this.
  16. DrSuSE

    DrSuSE New Member

    Joined:
    Sep 11, 2019
    Messages:
    6
    Likes Received:
    0
    As I use Join more, I am starting to notice some other odd things, all related to pics. I mostly mention this in case it helps you troubleshoot. So to recount, so far:

    1. MMS with only image fails (with image and text works)
    2. Only first image in received message is handled in app/extension

    Now for number 3... if I send someone (via my phone) a text with only a single image, Join will sometimes display that message as part of a recent group MMS conversation, even though it went specifically to one person and not the group.
     
  17. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,732
    Likes Received:
    739
    Ah that's very helpful! Thanks for the info! I'll try figure out why that could be happening!
     
: mms, no service

Share This Page