AutoVoice Use Google Assistant for AutoVoice commands

Learn how you can use Join and IFTTT to bring AutoVoice commands to Google Assistant

  1. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,488
    Likes Received:
    720
    joaomgcd submitted a new AutoApps project:

    Use Google Assistant for AutoVoice commands - Learn how you can use Join and IFTTT to bring AutoVoice commands to Google Assistant

    Read more about this project...
     
    KaszasM and joekeee like this.
  2. Elizabeth Ellis

    Elizabeth Ellis Member

    Joined:
    Nov 3, 2016
    Messages:
    34
    Likes Received:
    5
    Is there a way to use this to do searches on google? I'm not sure how to apply this to a broader context. I set up the profile a while back.
     
  3. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,488
    Likes Received:
    720
    If you don't say the autovoice keyword before the command it'll do a regular search on google :)
     
  4. joekeee

    joekeee New Member

    Joined:
    Oct 15, 2016
    Messages:
    11
    Likes Received:
    0
    How do you make a specific device listen to the "broadcast"?
    I'm referring to this step:
    I'm trying to set this up with my own webserver.
    The IFTTT applet fires and I have a variable with autovoice=:="input here".
     
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,488
    Likes Received:
    720
    joekeee likes this.
  6. joekeee

    joekeee New Member

    Joined:
    Oct 15, 2016
    Messages:
    11
    Likes Received:
    0
    Thanks for the advice!

    I'm setting it up with Android at the moment.
    It seems that AutoRemoteLite has limited features to send commands/messages to a device, I'll get the full AutoRemote and make it work that way :)
     
    Last edited: Nov 16, 2016
  7. Cyphermax

    Cyphermax New Member

    Joined:
    Feb 19, 2015
    Messages:
    1
    Likes Received:
    2
    Hey Joao, I was the one having the issue on G+ where my google home only responded with the confirmation word and nothing else. Well I did your suggestion and totally redid the whole IFTTT recipe this time I changed the confirmation to "yes sir" and the google home now responds with yes sir and actually runs the autovoice command. So for example I say "ok google, please turn off dining room" it responds with "yes sir" and tasker executes the command. But.....that's it the google home still will not do anything else. Won't answer questiosn, play music etc. All I get is "yes sir" and if it isn't an autovoice command nothing happens. Now I just realized I don't even have to say the keyword in my case "please". I can just say "ok google, turn off dining room" and it works. Its intercepting all words after ok google. I have absolutely no idea whats going on. Any suggestions are welcome. As always thanks for your help!
     
    Last edited: Nov 19, 2016
    JonC and Elizabeth Ellis like this.
  8. Craig Trunzo

    Craig Trunzo New Member

    Joined:
    Jul 13, 2016
    Messages:
    1
    Likes Received:
    0
    Hey João!

    This works great, but along the way, following your instructions, I realized it could be simplified.

    I ended up going from Google Assistant -» IFTTT -» AutoRemote. It lets you simplify the Join/AutoVoice part.
     
  9. Elizabeth Ellis

    Elizabeth Ellis Member

    Joined:
    Nov 3, 2016
    Messages:
    34
    Likes Received:
    5
    @Craig Trunzo
    I noticed Join is a lot faster than autoremote, so maybe that's the reason why. :) Whenever I have an option, I choose Join becuase for some reason my wifi and EG connection is so slow. It can take like a minute for it to do anything...so Join is a great tool for me. IDK though. If it works for you...cool. But if you find autoremote to be working slowly...then try join for somethings maybe.
     
  10. Unalloyedcube

    Unalloyedcube New Member

    Joined:
    Sep 1, 2015
    Messages:
    2
    Likes Received:
    0
    How can I "Say a phrase with both a number and a text ingredient" and pass the text and number to a variable in tasker. Currently, I am only getting the first variable.
     
  11. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,488
    Likes Received:
    720
    @Craig Trunzo I already had a tutorial for that with Join: http://forum.joaoapps.com/index.php...e-assistant-with-tasker-using-join-ifttt.206/ I just made this one specific for AutoVoice because with this you can re-use your existing AutoVoice setup and just use it right away with just one IFTTT applet :)

    @Unalloyedcube check this example: http://forum.joaoapps.com/index.php...e-assistant-with-tasker-using-join-ifttt.206/ If you use the AutoApps command system you can easily set multiple variables.
     
  12. Ben

    Ben New Member

    Joined:
    Feb 19, 2015
    Messages:
    11
    Likes Received:
    0
    @joaomgcd I have the example running triggering the splash on my target android device. I use the trigger word jarvis in the ifttt recipe, I am at a loss as to how to trigger my existing autovoice profiles. I'm sure it's something simple but I'm just not getting it :-( Any direction you can provide would be most appreciated!
     
  13. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,488
    Likes Received:
    720
    @Ben did you follow the tutorial?
     
  14. Ben

    Ben New Member

    Joined:
    Feb 19, 2015
    Messages:
    11
    Likes Received:
    0
    @joaomgcd Yes, I followed the tutorial. Issue is this, trigger word ends up on left side of =:= thus What comes through from assistant would be jarvis=:=turn on the kitchen lights. Toast shows "turn on the kitchen lights". AutoVoice recognize is seeing "turn on the kitchen lights" but my command word "jarvis" is missing since it is on the left side of the =:=. I suppose I could hard code the text string like this: Jarvis%3D%3A%3DJarvis%20 part write <<< {{TextField}}>>>

    Aside from that all of my AutoVoice Recognized commands use the Last Command Id for chaining, so my trigger profile sets the Command ID for further recursion. I do this to ensure that home automation commands are only triggered if the command string contains the trigger word jarvis. This approach may be out of date due to improvements in AutoVoice but I'm not sure now and if true, not sure how to change to simplify.
     
  15. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,488
    Likes Received:
    720
    Sorry for the delay in responding!
    Yes, if you want to make "Jarvis" part of the command you absolutely must use it at the right of "=:=" :) Hope this helps!
     
  16. Doug Graham

    Doug Graham New Member

    Joined:
    Dec 16, 2016
    Messages:
    1
    Likes Received:
    0
    @joaomgcd,
    It looks like the google assistant API is finally released. Do you have an idea of how hard it will be to implement and when it might be available in AutoVoice?
     
  17. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,488
    Likes Received:
    720
    Varazir likes this.
  18. Ben

    Ben New Member

    Joined:
    Feb 19, 2015
    Messages:
    11
    Likes Received:
    0
    No worries, I was away so just now getting back to this, thanks for confirming my suspicion.
     
  19. Elizabeth Ellis

    Elizabeth Ellis Member

    Joined:
    Nov 3, 2016
    Messages:
    34
    Likes Received:
    5

    I have the same thing. if I say autovoice before it, it will flash me something like auto voice command that i said or what ever i said.
    it doesn't write autovoice like AutoVoice. it's 2 words. this used to work. i messed around with some profiles thismorning, but after changing them back to original state (I'm pretty sure I did),
    if I say okay google, autovoice command, the command doesn't trigger at all.
    But if i say okay google command, the command triggers perfectly.
     
  20. Ben

    Ben New Member

    Joined:
    Feb 19, 2015
    Messages:
    11
    Likes Received:
    0
    I'm missing something fundamental here... The variable populated is %aacomm, all of my existing AV recognize commands are looking at %avcomm. How do I get it to re-process against that variable?
    Caveat emptor my current AV recognize tasks are all legacy and use the State condition.
    Thanks!
     
    Last edited: Jan 18, 2017

Share This Page