Open Volume level sets back to vibrate

Discussion in 'Tasker' started by Empring, Sep 26, 2019.

  1. Empring

    Empring New Member

    Joined:
    Sep 26, 2019
    Messages:
    10
    Likes Received:
    0
    Hi!

    So I was trying to set the volume level to some value while the screen is off and connected to wifi.
    I also set a notification after the volume level set so that I can hear it is no longer in vibrate mode.

    As soon as the phone connects to wifi I can hear the notification firing. But, when I press the power button to wake the phone up, the phone immediately buzzes and shows that it is went back to vibrate mode.

    Also checking the run log I can see the task fired, and it set the volume level, but it still went back to vibrate.
    Why is this happening?

    Also.. thinking that maybe this setting is not working on my device, I read about AutoTools that it can do every device setting. So I downloaded it, and did the neccessary permission thingies since my phone is not rooted. But immediately when I try to set a secure setting with it it, it shows a big dialog saying this is mostly a hack and I'm lucky if I this will work and even it is it mostly works on Nexus devices. This information is mention nowhere on the web (not on playstore, not on the help site, nowhere). Is the secure setting really only work on Nexus devices?
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,468
    Likes Received:
    795
    Hi. :)
    Can you please try long clicking your profile > Settings > Disable "Restore Settings" and then try again?
    Thanks in advance.
    About AutoTools, that notice is just related to the Mobile Data option, not about all the secure settings. :)
     
  3. Empring

    Empring New Member

    Joined:
    Sep 26, 2019
    Messages:
    10
    Likes Received:
    0
    Hi!

    Ohh wow. I'm really sorry. I didn't know about the "Restore Settings" option. That did solve this issue. Thank you!

    On the other hand the AutoTools notice seems it is not related just to the Mobile Data option. I'm talking about this dialog:
    Screenshot_20191001-152141.png

    One more question. Is there a way to get the RSSI value of a bluetooth beacon with Tasker?
    The BT Near profile works ok to detect a beacon, but I'd like to set a profile so when the phone is near a bluetooth beacon (with an RSSI value less then/greater than a set value) then unlock the device.

    If it is not available in Tasker now, can you implement this feature? I'd really like to use it.

    Thank you!
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,468
    Likes Received:
    795
    Oh I see what you mean. Yeah, that is generally true but it still works on a majority of devices. I just wanted to keep people's expectations low when trying it so they don't complain when something is not working :)

    To get the RSSI value you can use the BT connection action with the Scan option :) Hope this helps!
     
  5. Empring

    Empring New Member

    Joined:
    Sep 26, 2019
    Messages:
    10
    Likes Received:
    0
    Hmm.. BT connection action won't work for a beacon, because a beacon cannot be connected to. But I just found this:
    https://joaoapps.com/tasker-5-8/
    and it mentions Bluetooth info action which should work.

    But now I don't know If I should setup a BT Near state, or just a timer and run BT info action in it every x seconds?
    Which one would drain the batter faster?

    And I also read it somewhere that it takes 2 failed checks for BT Near to activate/deactivate.

    Essentially what I want is that, whenever the phone is near a beacon do an action (enter task), and whenever is not, do another action (exit task).
    I don't want to wait 2 consecutive scan periods for an action to take place. I want it do it either of the actions immediately whether it detected the beacon or not.

    Also it seemed when I tried this is that whenever the BT near profile detected the beacon it never went back to undetected phase (running exit task). Checked the run log and saw that it run the enter task once, but never run the exit task and it stayed green. (all checking is in the background while screen is off). Also modified the background check timeout to 300 and BT minimum timeout to 10, andwas waiting a lot longer than 5 mins.
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,468
    Likes Received:
    795
    Hi. Sorry for the late reply. Are you still having this issue?
     
  7. Empring

    Empring New Member

    Joined:
    Sep 26, 2019
    Messages:
    10
    Likes Received:
    0
    Sorry, the volume level issue is resolved. Should I create a new post for the questions on BT?
     
  8. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,468
    Likes Received:
    795
    Yes please!
     
: volume

Share This Page