AutoTools Web Screen, store files locally

Discussion in 'AutoApps' started by mcfrojd, Apr 1, 2017.

  1. mcfrojd

    mcfrojd New Member

    Joined:
    Oct 29, 2016
    Messages:
    13
    Likes Received:
    0
    When i move my html and image files to a local folder on the phone (instead of my previous hosted storage) /storage/emulated/0/Tasker/STORAGE/
    And i browse for the html file it's found in the path /storage/emulated/0/Tasker/STORAGE/hass_status.html
    and opens fine.
    But when i change the path for the images from http://domain.com:8123/local/image1.png
    to /storage/emulated/0/Tasker/STORAGE/image1.png
    I get broken link images on my Web Screen output.
    Is it not possible to use:
    <a href="autotoolscommand://screenPush=:=getLocation"><img alt="" src="/storage/emulated/0/Tasker/STORAGE/image1.png?dummy=%TIMES" /></a>
    when you have the files locally?
    Have tried these path to, since the html and images is in same folder.
    src="/image1.png?dummy=%TIMES"
    src="image1.png?dummy=%TIMES"
     
    Last edited: Apr 1, 2017
  2. mcfrojd

    mcfrojd New Member

    Joined:
    Oct 29, 2016
    Messages:
    13
    Likes Received:
    0
    If i dont use "inject" in web screed but use taskers "write file" with the html code generated with all my variables and then use web screen to view that local html, all images are shown when i use the path src="image1.png?dummy=%TIMES"
     
  3. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,481
    Likes Received:
    806
    Sorry, unfortunately you need to provide the full local path for the images when you use HTML injection. Relative file paths won't work unfortunately. That would be a nice think to have though, right? :) Maybe I can make it work. What do you think?
     

Share This Page