AutoNotification Activating notifications with no buttons

Discussion in 'AutoApps' started by scottishwildcat, Feb 2, 2020.

  1. scottishwildcat

    scottishwildcat New Member

    Joined:
    Feb 2, 2020
    Messages:
    9
    Likes Received:
    0
    I'm a Tasker noob, but have followed a couple of tutorials on this specifically and still can't get it to work.

    I'm trying to automate tapping on the "There's someone at your door" notification from the Ring app. The notification has no buttons, so normally you have to tap it, which opens the app to show the video stream. (Which is a terrible design for a doorbell app, but whatever.)

    I've set up an AutoNotification Intercept event, and then in the task it fires I'm trying to use AutoNotification Actions to simulate the tap. The Configuration page for AutoNotification Actions has a Button Text Filter, which says "if this is not specified, the notification itself of the matching notification will be pressed".

    Sounds like exactly what I want, but when I use that, it just fails with "could't find an action to perform".

    I can get all this to work fine with the Motion notification from the doorbell, which has two buttons (View and Snooze) -- AutoNotification Actions will happily tap the View button for me. What do I need to do to get this to work when there are no buttons?
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,338
    Likes Received:
    784
    You have to use the %antouchaction variable in that case :)
     
  3. scottishwildcat

    scottishwildcat New Member

    Joined:
    Feb 2, 2020
    Messages:
    9
    Likes Received:
    0
    Thanks... I've tried a tutorial that did that too, but it was a slightly different use case and I couldn't get it to work for me. Can you point me at a simple example?
     
  4. nirmalts

    nirmalts New Member

    Joined:
    Feb 4, 2020
    Messages:
    7
    Likes Received:
    1
    What a coincidence. I've been using Ring App with Auto Notification and it has always worked until Ring did an update last week (3.22.1). Since then it cannot find the notification to click, although the profile gets activated. I downloaded an APK of the previous version and it works fine.

    Gesendet von meinem ONEPLUS A6013 mit Tapatalk
     
    scottishwildcat likes this.
  5. scottishwildcat

    scottishwildcat New Member

    Joined:
    Feb 2, 2020
    Messages:
    9
    Likes Received:
    0
    Ah... so it could be an issue with the app then. I did wonder about that :(

    I presume it should be possible to make it work with something like AutoInput instead?
     
  6. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,338
    Likes Received:
    784
  7. scottishwildcat

    scottishwildcat New Member

    Joined:
    Feb 2, 2020
    Messages:
    9
    Likes Received:
    0
    Thanks... have installed it but probably won't be able to test until tomorrow.
     
  8. nirmalts

    nirmalts New Member

    Joined:
    Feb 4, 2020
    Messages:
    7
    Likes Received:
    1
    I had tested and given you a feedback via email that the version fixes an illegal argument exception but does not make it work with the Ring App.

    I checked the notification from the Ring App again and saw that, for every notification the latest App throws the notification element twice. Once with "AppName - null" and another one with "AppName - Notification Text". It looks like Auto Notification is intercepting the first one.

    Gesendet von meinem ONEPLUS A6013 mit Tapatalk
     
  9. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,338
    Likes Received:
    784
    Yeah, try only intercepting the second one and it should work :) To do that you can set the text filter to something like
    Code (Text):
    .+
    for example and enable regex for the text filter.
     
    nirmalts likes this.
  10. nirmalts

    nirmalts New Member

    Joined:
    Feb 4, 2020
    Messages:
    7
    Likes Received:
    1
    Sure, I will try this out and give a feedback. Is it a bug from the App that it is throwing a notification with "null"? I did see some more Apps in the Notification list doing the same (luckily I don't have a need to intercept them).

    Gesendet von meinem ONEPLUS A6013 mit Tapatalk
     
  11. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,338
    Likes Received:
    784
    Nope, it's probably intercepting the group notification which is invisible and that's probably the issue.
     
  12. scottishwildcat

    scottishwildcat New Member

    Joined:
    Feb 2, 2020
    Messages:
    9
    Likes Received:
    0
    Have you tried with the Rapid Ring app to see if it does it differently? That's what I'm trying to use, except for some reason the Rapid Ring app doesn't even show up in the list of apps I can intercept, and I haven't tried to figure out what its package ID is yet instead ;)
     
  13. nirmalts

    nirmalts New Member

    Joined:
    Feb 4, 2020
    Messages:
    7
    Likes Received:
    1
    Rapid Ring had an Interception problem from the very beginning similar to what Ring App has now after the latest update. If the tip above works with the Ring App, I guess it will work with Rapid Ring as well I guess.

    Gesendet von meinem ONEPLUS A6013 mit Tapatalk
     
  14. scottishwildcat

    scottishwildcat New Member

    Joined:
    Feb 2, 2020
    Messages:
    9
    Likes Received:
    0
    Good to know, thanks!
     
  15. nirmalts

    nirmalts New Member

    Joined:
    Feb 4, 2020
    Messages:
    7
    Likes Received:
    1
    It works now!

    It was simply a problem of me not using %antouchaction in the task correctly (it was somehow not required before the Ring App update). It works with Rapid Ring App as well. See Tasker Profile and Task below.
    Code (Text):
    Profil: Ring on Notification (31)
            Restore: no
            Ereignis: AutoNotification Intercept [ Konfiguration:Event Behaviour: true
        Notification Type: Only Created Notifications
        Notification Apps: Rapid Ring
        Notification Title: Jemand ist an Haustür ]
        Eingang: Start Rapid Ring (32)
            A1: Taste [ Taste:Zurück ]
            <Open Rapid Ring>
            A2: AutoNotification Actions [ Konfiguration:Intercept Action ID: %antouchaction Timeout (Sekunden):20 ]
            <Preview Rapid Ring>
            A3: Warte [ MS:0 Sekunden:45 Minuten:0 Std.:0 Tage:0 ]
            <Disconnect Rapid Ring>
            A4: AutoInput Action [ Konfiguration:Type: Id
        Value: com.ring.answer:id/hangup
        Action : Click
        Is Tasker Action: true Timeout (Sekunden):2 ]
            A5: Warte [ MS:0 Sekunden:4 Minuten:0 Std.:0 Tage:0 ]
            <Show Home-Screen>
            A6: Home-Screen anzeigen [ Seite:0 ]
    https://taskernet.com/shares/?user=...HzVhVAJNsmio2&id=Profile:Ring+on+Notification
     
  16. scottishwildcat

    scottishwildcat New Member

    Joined:
    Feb 2, 2020
    Messages:
    9
    Likes Received:
    0
  17. nirmalts

    nirmalts New Member

    Joined:
    Feb 4, 2020
    Messages:
    7
    Likes Received:
    1
    Forget the import. There are not many steps anyways. Did you try creating the profile/task manually looking at the above? Steps A1. and A6. are optional. I do A1. as I have screensaver running on the tab all the time. A6. is because I want to hide th Rapid Ring App after it disconnects.
     
  18. scottishwildcat

    scottishwildcat New Member

    Joined:
    Feb 2, 2020
    Messages:
    9
    Likes Received:
    0
    I tried it, but I'm still getting "The variable %antouchaction doesn't have a value".

    You'd think as a developer myself I should be able to figure out this sort of thing ;)

    EDIT: Got it working eventually. No idea why or what I changed, but thanks for your help!
     
    Last edited: Feb 8, 2020
  19. nirmalts

    nirmalts New Member

    Joined:
    Feb 4, 2020
    Messages:
    7
    Likes Received:
    1
    Do you have in your profile for the Rapid Ring a filter for "Notification Title" (the Ring notification has no "Notification Text")? If you copied it from the existing notification, you could also remove the yellow bell icon that gets added to the title. In your Task, do not add any filter (even for the App), and add only %antouchaction.
    By the way, don't question your developer skills with this. As a developer you would normally put a break-point and debug such things :) Here, as you are working at a higher level, you need to rely on console outputs and some trial and error ;)
     
  20. scottishwildcat

    scottishwildcat New Member

    Joined:
    Feb 2, 2020
    Messages:
    9
    Likes Received:
    0
    ;) Yes, I think it may have been adding the notification title filter that made it work. All good now. Thanks again!
     

Share This Page