AutoRemote AutoRemote on Linux

Discussion in 'AutoApps' started by Glenn Delmotte, Mar 3, 2015.

  1. Glenn Delmotte

    Glenn Delmotte New Member

    Joined:
    Feb 22, 2015
    Messages:
    13
    Likes Received:
    1
    I manged to get autoRemote working on my linux Homeserver. And when I send basic commands ( like 'ls') it's working just fine.

    On the other hand when I would like to reboot my homeserver (sudo reboot) nothing is happening.

    The login and password I provided in the settings belong to a user with sudo rights.

    Any idea on how to solve this?
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,488
    Likes Received:
    718
    Sorry, I think it must be something related to your user. I just tried that myself and it worked for me. Sorry to not be of much help.
     
  3. L.Drake

    L.Drake Member

    Joined:
    Feb 12, 2015
    Messages:
    61
    Likes Received:
    1
    I've setup a user with the NOPASSWD: addition and disabled local login for automated things like ARemote (I'm using my own little client though, still in pre-alpha), and everything works well
     
  4. Glenn Delmotte

    Glenn Delmotte New Member

    Joined:
    Feb 22, 2015
    Messages:
    13
    Likes Received:
    1
    I figured out how to do this.

    First i've created a new user with sudo rights, then i edited visudo and added the following at the bottom:

    username ALL=NOPASSWD: ALL

    Replace username with the username of the user you want to allow a passwordless sudo. So if the user is calvin, you would enter:

    calvin ALL=NOPASSWD: ALL
     
: autoremote, linux

Share This Page