AutoTools Connect to the Best Available Wifi Network

Make sure that the network connection your connected to has the best signal

  1. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Unfortunately I really wouldn't know. All AutoTools does is call an Android API to connect so if it doesn't work I don't think there's much I can do about it...
     
  2. Kohjb

    Kohjb New Member

    Joined:
    Dec 6, 2017
    Messages:
    4
    Likes Received:
    0
    Ok, thanks for the reply. Any chance you can let me know which API you are calling to effect the change? I'll look for clues as to why its not working and report back here if I find anything.
     
  3. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
  4. Tulio

    Tulio New Member

    Joined:
    Jun 3, 2020
    Messages:
    5
    Likes Received:
    0
    Hi, I get %err = 2 in AutoTools Conectivity. What error is that?
    If I open the app, the error does not happen.
     
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
  6. Tulio

    Tulio New Member

    Joined:
    Jun 3, 2020
    Messages:
    5
    Likes Received:
    0
    Thanks for the answer, but Ive already have this version, anyway, I reinstalled it and it didnt work.
    I've activated all the permissions (storage, local, overlay, change configs) and disabled battery optimization. I have Android 10 and Zenfone 6. The plugin AutoTools Conectivity returns

    10.38.53/ActionArgBundle key: WakeOnLanMacAddress: replace <null> String value with null
    10.38.53/ActionArgBundle key: WakeOnLanIpAddress: replace <null> String value with null
    10.38.53/ActionArgBundle key: BluetoothDeviceAddress: replace <null> String value with null
    10.38.53/ActionArgBundle key: Ping: replace <null> String value with null
    10.38.53/ActionArgBundle key: ForceConnectBluetooth: replace <null> String value with null
    10.38.53/ActionArgBundle key: USSDCode: replace <null> String value with null
    10.38.53/ActionArgBundle key: WakeOnLanPort: replace <null> String value with null
    10.38.53/ActionArgBundle key: ConnectToNetwork: replace <null> String value with null
    10.38.53/ActionArgBundle key: BluetoothTethering: replace <null> String value with null
    10.38.53/ActionArgBundle key: BluetoothDeviceName: replace <null> String value with null
    10.38.53/E FIRE PLUGIN: AutoTools Connectivity / com.twofortyfouram.locale.intent.action.FIRE_SETTING: 21 bundle keys
    10.38.53/E AutoTools Connectivity: plugin comp: com.joaomgcd.autotools/com.joaomgcd.autotools.broadcastreceiver.IntentServiceFire
    10.38.53/E add wait type Plugin130 time 15
    10.38.53/E add wait type Plugin130 done
    10.38.53/E handlePluginFinish: taskExeID: 130 result 3
    10.38.53/E pending result code
    10.38.53/E add wait task
    10.39.08/E Erro: null
     
    Last edited: Jun 23, 2020
  7. Tulio

    Tulio New Member

    Joined:
    Jun 3, 2020
    Messages:
    5
    Likes Received:
    0
    Could you help me Joao?
     
  8. Tulio

    Tulio New Member

    Joined:
    Jun 3, 2020
    Messages:
    5
    Likes Received:
    0
    Hi João, I uninstalled my autotools app, reinstalled it from your link, opened it, gave all permitions asked. I opened tasker again, redo the task with wifi Autotools Conectivity, opened the plugin, checked ok when asked one more permission. I also checked that optmization was already disable. When I run the plugin it returns the same error.
    I'm doing everything righ? Does it lacks any step?
     
  9. Tulio

    Tulio New Member

    Joined:
    Jun 3, 2020
    Messages:
    5
    Likes Received:
    0

Share This Page