AutoWeb Netatmo API

Discussion in 'AutoApps' started by AgP42, Sep 26, 2019.

  1. AgP42

    AgP42 New Member

    Joined:
    Aug 24, 2019
    Messages:
    15
    Likes Received:
    0
    Hi,

    I discover recently AutoWeb and I am really looking forward to add new API on it !

    I saw there is already an API for Netatmo weather (it is named "neatmo") so I import it and it works fine (I create the client id and everything on the netatmo website to allow the Oauth2WithRefresh to work).

    But this existing AutoWeb API only connect to the action "getstationsdata" that gives the infos of my own stations (API doc here : https://dev.netatmo.com/resources/technical/reference/weather/getstationsdata), here is the configuration :
    [​IMG]

    I wanted to add another action for the "getpublicdata" to be able to get the data of other public stations (API doc here : https://dev.netatmo.com/resources/technical/reference/weatherapi/getpublicdata)
    So I add a new action on the same API, I duplicate the original one and change the path and id, and I add the other mandatory inputs :
    [​IMG] [​IMG]

    After that I tried to generate the outputs, but AutoWeb gives me the outputs of the other action (getstationsdata) and when I return, he finally told me that my access_token is invalid. Or sometimes (I did several differents try !) he just don't get any output, but I always have this access_token error at the end :
    [​IMG]

    I tried to delete both actions and create only the "getpublicdata" one but still the token error. I also tried to add the "access_token" as an input parameter and even to skip all the inputs parameters (to try to see if another error will occurs...), but whatever I do I still have this token error only for this "getpublicdata" action.

    I also checked that the "scope" of my access_token allow to get thoses both infos that is correct.

    So I run out of ideas, any clue what did I miss to make that API working ?

    Thanks a lot in advance of any help :)

    AgP
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,570
    Likes Received:
    728
    Hi there. Sorry for the delay. Are you still having these issues?
     
  3. AgP42

    AgP42 New Member

    Joined:
    Aug 24, 2019
    Messages:
    15
    Likes Received:
    0
    Hello,

    not really, but I found another way.

    Using AutoWeb it is still not working, but I could make it work using the new Tasker action "HTTP Auth" + "HTTP Request" + "AutoTools Json Read"

    It is more complicated but at least it doesn't request the beta apps that many people don't have.

    I will publish it on TaskerNet when ready !

    (For now I already have done the "getstationdata", it is here : https://forum.joaoapps.com/index.php?resources/netatmo-weather-station.415/)

    Bye,
    AgP
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,570
    Likes Received:
    728
    Cool! Glad you got it! :)
     
: AutoWeb, Netatmo, API

Share This Page