Solved Sending Tasker Commands

Discussion in 'Join' started by flu13, Feb 25, 2016.

  1. flu13

    flu13 Member

    Joined:
    Jun 18, 2015
    Messages:
    50
    Likes Received:
    3
    Anyone have any guidance on how to use Join to trigger Tasker? I have a task on my phone to toggle the wifi hotspot. I turn it on when I'm at work sometimes so that I can listen to Pandora (which is not allowed on our work network) via my computer. I'd like to trigger that from Join rather than having to do it from my phone. Do I need AutoApps for this?
     
  2. Stupifier

    Stupifier Member

    Joined:
    Mar 10, 2015
    Messages:
    147
    Likes Received:
    6
    Yes, you need AutoApps. Once you have it, you just create an Event trigger with AutoApps. In the settings for the event, you just set Join as the app and whatever "Command" word you want to set up to trigger the event from your computer. Link that to your Wifi HotSpot task.

    Also, be sure you have Accessibility and/or Admin privileges given to Join and AutoApps....can't remember if it is necessary...but it might be.
     
  3. Stupifier

    Stupifier Member

    Joined:
    Mar 10, 2015
    Messages:
    147
    Likes Received:
    6
    In tasker, create a profile, choose Event, then go to plugins, Autoapps. Then press on the pencil looking thing to access the options for the Autoapps event you just made.

    Not gonna explain any further, sorry... Just experiment and you'll learn more quicker.

    Sent from my SM-G900V using Tapatalk
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,355
    Likes Received:
    711
    You don't need AutoApps actually :) You can just use the Join Tasker event condition if you want. AutoApps is just another option for people who have already setup a lot of stuff with it and want to reuse it with Join.
     
  5. flu13

    flu13 Member

    Joined:
    Jun 18, 2015
    Messages:
    50
    Likes Received:
    3
    Well, I can't quite figure it out. When I use Join to send a command, I get that little pop-up. I type something into it, for example, "xx." It shows the message saying that it sent the command "=:=xx" to Tasker. On my phone, I set a Join Receive Push Text event, and I've tried both "xx" as the text and "=:=xx" but neither seems to do anything. There's probably something obvious I'm doing wrong.
     
  6. flu13

    flu13 Member

    Joined:
    Jun 18, 2015
    Messages:
    50
    Likes Received:
    3
    Ooohhhh.....wait a sec. Just found this setting: Add the "jointextpush=:=" prefix to Tasker commands so that the Join AutoApps condition automatically supports sent commands.

    This might be what I needed.
     
  7. flu13

    flu13 Member

    Joined:
    Jun 18, 2015
    Messages:
    50
    Likes Received:
    3
    Boom. Got it.
     
  8. AssassinsLament

    AssassinsLament New Member

    Joined:
    Jun 2, 2015
    Messages:
    12
    Likes Received:
    0
    joaomgcd can you give a quick tutorial on how to do it with join command? I've tried every combination I could think of and I'm just not getting it.

    I'll explain what I did on join, I guess that might help.

    Sender:
    Tasker -> task -> plugin -> join -> configuration -> device = receiver, text = jointextpush=:=example

    Receiver:
    Tasker-> event -> plugin -> join -> configuration -> text -> text filter = example

    -> run task

    and it's not working for me.
    I have tried text filter = example
    I have tried text filter = jointext=:=example
    I have tried text filter = %jointext=:=example
    I have tried text filter = joincomm=:=example
    I have tried text filter = %joincomm=:=example
    I have tried text filter = jointextpush=:=example
    I have tried text filter = %jointextpush=:=example

    I get the text in join, but it never triggers my task.

    Thanks in advance!
     
  9. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,355
    Likes Received:
    711
    If you send "jointextpush=:=example", then on the receiver you have to match that. :)
    So, for example "jointextpush=:=example" on the receiver's condition should work
    "jointextpush=:=" should also work for example
    Just make sure to exit tasker every time you change the receiver's command filter or it won't save the changes.

    Hope this helps
     
  10. AssassinsLament

    AssassinsLament New Member

    Joined:
    Jun 2, 2015
    Messages:
    12
    Likes Received:
    0
    It's still not working for me. I do receive the text on the receiver inside join, but it's not triggering the task. The text is exactly the same on the sender and receiver. I'm baffled.

    edit:

    Ok, what's weird is that it works if I do the same thing reversed (from receiver to sender). So I must have something mis-configured on the receiver. What could be blocking the triggering?

    edit #2:

    I uninstalled tasker and all AutoApps stuff and join, and reinstalled starting with tasker first, and it works now. Not sure what happened but just in case if anyone has similar problems, always make sure tasker is installed first before any tasker addon/plugin.
     
    Last edited: Feb 29, 2016
  11. Mike Park

    Mike Park New Member

    Joined:
    Dec 22, 2015
    Messages:
    12
    Likes Received:
    0
    Do you have to set a new profile for each command you send from join. Say I have a two commands, Test1 and Test2 which has an event of Flash Test (Test1, Test2). Would there need to be two Join Received push profiles? or can it be done in a variable somewhere, if so is it done in the Profile or the Event. Sorry I'm struggling to quite understand, ideally I don't want to create a profile for every Tasker command that I have.
     
  12. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,355
    Likes Received:
    711
: Tasker, AutoApps

Share This Page