AutoTools Turn GPS on when in Google Maps, turn it off otherwise (No Root!)

Enable and disable location settings at will with AutoTools Secure Settings

  1. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,059
    Likes Received:
    690
    joaomgcd submitted a new AutoApps project:

    Turn GPS on when in Google Maps, turn it off otherwise (No Root!) - Enable and disable location settings at will with AutoTools Secure Settings

    Read more about this project...
     
  2. Meyrcr

    Meyrcr New Member

    Joined:
    Oct 19, 2016
    Messages:
    3
    Likes Received:
    0
    I get this error when i try the High Accuracy setting:
    09.44.46/E FIRE PLUGIN: AutoTools Secure Settings / com.twofortyfouram.locale.intent.action.FIRE_SETTING: 5 bundle keys 09.44.46/E AutoTools Secure Settings: plugin comp: com.joaomgcd.autotools/com.joaomgcd.autotools.broadcastreceiver.BroadcastReceiverFire 09.44.46/E add wait type Plugin1 time 60 09.44.46/E add wait type Plugin1 done

    Phone: Sony Z5
     
  3. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,059
    Likes Received:
    690
    Sorry, but that doesn't actually tell me what the error is. Can you please enable the "Continue Task on Error" option in the action that's giving you the error and on the next step use a flash action with the text %errmsg?
    Thanks in advance
     
  4. Meyrcr

    Meyrcr New Member

    Joined:
    Oct 19, 2016
    Messages:
    3
    Likes Received:
    0
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,059
    Likes Received:
    690
  6. Meyrcr

    Meyrcr New Member

    Joined:
    Oct 19, 2016
    Messages:
    3
    Likes Received:
    0
    Great Thx! It worked.
    Sorry i missed that part somehow.
    Thx for all your apps. I am a premium user, and also try out a lot of Beta apps.
    But still make a lot of mistakes :)
    Thx and keep up the hard work!
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,059
    Likes Received:
    690
    No problem! :) Glad you got it!
     
  8. SeanR

    SeanR New Member

    Joined:
    Oct 26, 2016
    Messages:
    7
    Likes Received:
    0
    I am having an issue getting the "adb shell pm grant com.joaomgcd.autotools android.permission.WRITE_SECURE_SETTINGS" command to work when in Minimal ADB and Fastboot. I really need some help on this. I am getting the error message on my Nexus 6P running Pure Nexus 7.0 ROM when I try to use this. I followed your instructions on how to grant permission.
    Capture.JPG
     
  9. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,059
    Likes Received:
    690
    make sure that no extra space is added at end or something like that... What android version are you using?
     
  10. SeanR

    SeanR New Member

    Joined:
    Oct 26, 2016
    Messages:
    7
    Likes Received:
    0
    I made sure to type the command exactly as shown . I am using pure Nexus 7.0 rom.
     
  11. SeanR

    SeanR New Member

    Joined:
    Oct 26, 2016
    Messages:
    7
    Likes Received:
    0
    Still need some help getting this to work. Help would be greatly appreciated.
     
  12. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,059
    Likes Received:
    690
    Just to be sure: did you type the command manually or did you copy-paste it directly?
     
  13. SeanR

    SeanR New Member

    Joined:
    Oct 26, 2016
    Messages:
    7
    Likes Received:
    0
    I typed it manually 5 times
     
  14. SeanR

    SeanR New Member

    Joined:
    Oct 26, 2016
    Messages:
    7
    Likes Received:
    0
    Still need some help, kind sir. Anything that you can do would be awesome.
     
  15. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,059
    Likes Received:
    690
    I know I'm being kinda of a pain, but could you please copy-paste it directly? Sometimes we just miss something tiny when manually typing things out... Sorry about that.
     
  16. SeanR

    SeanR New Member

    Joined:
    Oct 26, 2016
    Messages:
    7
    Likes Received:
    0
    You are not being a pain. In fact, I just tried copying and pasting and IT WORKED!!! I have no idea why it didn't after meticulously typing it over and over, but I am all set now. Thank you for not getting frustrated with me. Keep up the great dev work. I will be buying this full version for sure!
     
  17. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,059
    Likes Received:
    690
    Glad you finally got it :)

    No problem. That's why I NEVER manually write stuff like this these days. This has happened to me too many times already. :p
     
  18. naeem rasul

    naeem rasul New Member

    Joined:
    Mar 18, 2017
    Messages:
    1
    Likes Received:
    0
    you say NO ROOT REQUIRED yet you say to download ADB (Android Debug Bridge), which is a rooting software. hmmmmmm.
     
  19. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    8,059
    Likes Received:
    690
  20. WWWilco

    WWWilco New Member

    Joined:
    Feb 13, 2017
    Messages:
    1
    Likes Received:
    0
    I have been using autotools for some time now and I cannot solve this.

    The procedure as described works perfectly on my OnePlus T3 for Google Maps. Also for some other navigation apps.
    When I drive my care I like to use Waze for navigation. I'm have some troubles to activate my GPS when starting Waze.

    The setup is identical as described in "Turn GPS on when in Google Maps, turn it off otherwise (No Root!)"
    The selected Apps are Maps and Waze. When starting Maps the GPS will turn on, when starting Waze the location services will not switch from off to on.

    Anybody any suggestions?
     

Share This Page