AutoVoice Use Amazon Echo Routines to run any Tasker task 2018-06-19

Learn how to map routines to Tasker tasks using the AutoVoice Smart Home system

  1. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,449
    Likes Received:
    793
    joaomgcd submitted a new AutoApps project:

    Use Amazon Echo Routines to run any Tasker task - Learn how to map routines to Tasker tasks using the AutoVoice Smart Home system

    Read more about this project...
     
  2. Springs

    Springs New Member

    Joined:
    Jun 21, 2018
    Messages:
    1
    Likes Received:
    0
    if i wanted to control the playback of a music app, do i have to have a separate profile within tasker to trigger each option like pause / skip or is there a way to have one profile that does it all?
     
  3. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,449
    Likes Received:
    793
    You could make the profile trigger on all the actions you want to support and then in the task use If actions to do different stuff with different actions :)
     
  4. Nachman Ross

    Nachman Ross New Member

    Joined:
    Jun 22, 2018
    Messages:
    1
    Likes Received:
    0
    Can someone help me with the AutoVoice Smart Home Alexa skill. I’m currently using the original AutoVoice skill with Alexa to provide my wife who is a quadriplegic the ability to change channels on Roku and to control her hospital bed via voice commands. Today, I attempted to use the new AutoVoice Smart Home skill to simplify everything so that she doesn’t have to say “Tell AutoVoice”. I enabled the new skill and within the AutoVoice app I created two new Alexa Smart Home devices “Bedroom Roku” and “Probed”. Both of these devices now show up in the Alexa app when I list my Smart Home Devices and click on “All Devices”.

    Here’s where things start to fail. In the Alexa app, I’m trying to create a Routine in which I say the phrase “BBC”. After I save this phrase I select “Add Action” and then “Smart Home” and then “Control Device” but I don’t see my new devices “Bedroom Roku” and “Probed” in the list of devices. So I can’t complete the routine.

    In attempting to debug the problem, I find that if I say “Alexa Change Channel to BBC on Bedroom Roku”, the Tasker program on my tablet flashes a toast message that it received a “ChangeChannel” message with the Channel name of “”BBC” so Alexa and my tablet is communicating through the new skill. I’m even able to create a profile which reacts to this message and which runs a ChangeChannel task.

    So what I need is the proper way to successfully create a Routine in which the phrase “Alexa BBC” will be sent to the Bedroom Roku device that I created so that my wife doesn’t have to say some many words in the phrase.
     
  5. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,449
    Likes Received:
    793
    Hi :) Replied to you in private, correct?
     
  6. dastrix

    dastrix Member

    Joined:
    Jan 8, 2019
    Messages:
    36
    Likes Received:
    0
    Hi All

    Im trying to trigger a task using 'Alexa, answer call'

    It seems I can turn on lights and so on, but I dont want any of that. I just want to issue a voice command to run my tasker action. I can create a routine in the alexa app, but the action is where I fall down. It shows my Android Device but only allows lighting functions, on, off, dim etc.

    I cant seem to find a tutorial to do what I need, is it possible?

    Thanks

    Scenario:

    I have an intercom on my front gate which makes a SIP call to a wall mounted Android tablet running Tasker And Zoipher. I have been able to auto answer the call using AutoInput and Gesture. What I need to do now is if im in the house, I want to issue a voice command to one of my many Echo devices 'Alexa, Answer call' which will trigger Tasker on the Android device to Auto Accept the call.

    Hopin someone can help :) I bought a few of the AutoApps in an attempt to get it working. Ive enabled the Smart Home Skill
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,449
    Likes Received:
    793
    Did you see the actual tutorial? :) It shows how to run any task using the routines, step by step!
     
  8. Arunas Jocius

    Arunas Jocius New Member

    Joined:
    Mar 21, 2019
    Messages:
    6
    Likes Received:
    0
    Both AutoVoice and tasker have to be open in order for this routine to work, right? Can I auto open those two apps when I am at home?
     
  9. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,449
    Likes Received:
    793
    Nope. Neither have to be open :)
     
  10. Arunas Jocius

    Arunas Jocius New Member

    Joined:
    Mar 21, 2019
    Messages:
    6
    Likes Received:
    0
    Hmm, does not work without opening for me. Huawei P20 Pro. Followed Tutorial, all works when apps are open, does not when closed
     
  11. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,449
    Likes Received:
    793
  12. Diodato

    Diodato New Member

    Joined:
    May 13, 2019
    Messages:
    1
    Likes Received:
    0
    Solved
    --------

    No matter what I do my Alexa App does not detect any Virtual Device I create. Any help would be appreciated.

    Here is what I am doing:
    - in AutoVoice under Alexa Smart Home Devices I add lets say a "Lamp" with "Set Brightness" and "On/Off" capabilities. Ok, get the popup "Saved Lamp" and the Example Commands for Lamp.
    - in Amazon Alexa App under Devices I try to Add Device - Other and Discover Devices. After 20s "No new devices found". Only my old ones are listed.
    In the Alexa App the AutoVoice skill is enabled and linked to my account.
    I tried disabling and re-enabling the Skill but the Alexa App just wont discover the AutoVoice created Virtual Devices.
    --------
    I needed to additionally add the AutoVoice Smart Home skill in Alexa App.
     
    Last edited: May 14, 2019
  13. Guy Perry

    Guy Perry New Member

    Joined:
    Nov 26, 2018
    Messages:
    6
    Likes Received:
    0
    Hi, I was able to create a virtual device in Autovoice and Alexa recognized the device. I am trying to use the virtual device in an Alexa routine, but the device does not appear in the Smart Home device list.

    Thanks.
     
  14. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,449
    Likes Received:
    793
    What capabilities did you give the device?
     
  15. Guy Perry

    Guy Perry New Member

    Joined:
    Nov 26, 2018
    Messages:
    6
    Likes Received:
    0
    The only capability that was turned on was Set Volume. When I added capabilities it appeared in the device list in routines, but I can't use the routine to change the volume, which is what I wanted to achieve.

    What I want to achieve is to mute my phone as part of a routine.
     
    Last edited: Jul 6, 2019
  16. Guy Perry

    Guy Perry New Member

    Joined:
    Nov 26, 2018
    Messages:
    6
    Likes Received:
    0
    It only allows me to turn the device on or off.
     
    Last edited: Jul 7, 2019
  17. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,449
    Likes Received:
    793
    Hhmm, maybe routines doesn't support changing volumes on devices? :(
     
  18. Sterling Poteat

    Sterling Poteat New Member

    Joined:
    Apr 30, 2015
    Messages:
    3
    Likes Received:
    0
    I'm having the same issue, I have created an Autovoice Smart Home device that Turn On/Off, Set Channel, Set Color, and Set Input. When I select the Autovoice device in my Alexa routine, I only get the Action Turn On/Off and Set Color. I really want to Set Input and/or Set Channel. Why are these actions not showing up. (In the description of the Alexa Autovoice skill you indicate that this is a feature). Also when commanding the Alexa is in "Alexa, ask Autovoice AV Television to set channel to 2", Alexa says that it sent the command but it does not run the Tasker profile that I have set up. But adding the Autovoice smart device to a routine and calling the routine, it runs the Tasker profile. Please help
     
    Last edited: May 21, 2020

Share This Page