AutoVera What is the variable for smart switch and door sensor?

Discussion in 'AutoApps' started by 9ixxer Lee, Dec 26, 2017.

  1. 9ixxer Lee

    9ixxer Lee New Member

    Joined:
    Jul 25, 2015
    Messages:
    16
    Likes Received:
    0
    For some reason autovera cannot seems to recognise the variable coming from above devices and I am unable to perform a status update.

    Is there anyway I can check what variable is generated via autovera when I activate the devices?

    Sent from my SM-G955F using Tapatalk
     
  2. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Hi there. Did you try using the AutoVera Device Info action to get their variables? Thanks
     
  3. 9ixxer Lee

    9ixxer Lee New Member

    Joined:
    Jul 25, 2015
    Messages:
    16
    Likes Received:
    0
    how about do I do that?
    please assist.
    thanks

    Sent from my SM-G955F using Tapatalk
     
  4. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Just use the mentioned action in the task :)
     
  5. 9ixxer Lee

    9ixxer Lee New Member

    Joined:
    Jul 25, 2015
    Messages:
    16
    Likes Received:
    0
    ok thanks I have found the device info....but which variables shall I use for a smart switch on and off variables as I dun know what is generated from the device? normally on is 0 and on is 1 right?

    I try both on avstatus still not reporting T.T [​IMG][​IMG]

    Sent from my SM-G955F using Tapatalk
     
  6. 9ixxer Lee

    9ixxer Lee New Member

    Joined:
    Jul 25, 2015
    Messages:
    16
    Likes Received:
    0
    I managed to get feedback finally by using back %avnewstatus and define the new and old variables to 1 & 0.

    But what is strange is the else if don't work. end up I need to create a separate profile for open or close.

    How to make them in to a single profile where the else if will work?

    Sent from my SM-G955F using Tapatalk
     
  7. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Can you please export your profile's description (not xml) so I can take a look? Long-click the profile in Tasker->export description Thanks in advance
     
  8. 9ixxer Lee

    9ixxer Lee New Member

    Joined:
    Jul 25, 2015
    Messages:
    16
    Likes Received:
    0
    please see below....I check again something is wrong.
    I tried again on the switch it is still not getting variables T.T





    Profile: Dyson Charging Status (88)
    Event: AutoVera Status Update [ Configuration:Vera: Gix Veraplus
    Device: Store Smart Switch
    Service: Power Switch
    Variable: Status
    Old Value: 0
    New Value: 1 ]
    Enter: Anon (89)
    A1: AutoVera Settings [ Configuration:Vera: Gix Veraplus
    Device: Store Smart Switch
    Status Updates: Enable Timeout (Seconds):0 ]
    A2: AutoVera Devices Info [ Configuration:Vera: Gix Veraplus
    Device: Store Smart Switch
    Room: KITCHEN Timeout (Seconds):60 ]
    A3: If [ %avstatus() ~ 0 ]
    A4: Say [ Text:%avname() had completed your dyson vaccum charging process Engine:Voice:default:default Stream:3 Pitch:4 Speed:4 Respect Audio Focus:On Network:Off Continue Task Immediately:Off ]
    A5: Else If [ %avstatus() ~ 1 ]
    A6: Say [ Text:%avname() had began your dyson vaccum charging process Engine:Voice:default:default Stream:3 Pitch:5 Speed:5 Respect Audio Focus:On Network:Off Continue Task Immediately:Off ]
    A7: End If


    Sent from my SM-G955F using Tapatalk
     
  9. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Can you please use a Flash action before A3 with %avstatus() to check what it contains? thanks!
     
  10. 9ixxer Lee

    9ixxer Lee New Member

    Joined:
    Jul 25, 2015
    Messages:
    16
    Likes Received:
    0
    flash action?

    Sent from my SM-G955F using Tapatalk
     
  11. 9ixxer Lee

    9ixxer Lee New Member

    Joined:
    Jul 25, 2015
    Messages:
    16
    Likes Received:
    0
    ok understood.
    the variables flashed is 0 when I tested the task itself.

    But still cannot works. it seem that the variables from the smart switch is not what 0 or 1?[​IMG]

    Sent from my SM-G955F using Tapatalk
     
  12. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    So you're saying that the variable is always 0 even if the device is on at the time?
     
  13. 9ixxer Lee

    9ixxer Lee New Member

    Joined:
    Jul 25, 2015
    Messages:
    16
    Likes Received:
    0
    no I meant I try to toggle the switch physically but tasker is not getting the variables 0 or 1 I guess. therefore it does not work

    Sent from my SM-G955F using Tapatalk
     
  14. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Hmm, but the flash action does show 0. So it seems the variable is correct?
     
  15. 9ixxer Lee

    9ixxer Lee New Member

    Joined:
    Jul 25, 2015
    Messages:
    16
    Likes Received:
    0
    that's puzzle me as well as well. T.T
    I am not sure as well what to do next



    Sent from my SM-G955F using Tapatalk
     
  16. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Can you clarify exactly what isn't working? Is it the say actions?
     
  17. 9ixxer Lee

    9ixxer Lee New Member

    Joined:
    Jul 25, 2015
    Messages:
    16
    Likes Received:
    0
    I toggled the actual smart switch but the tasker does not response to the status at all whether if I on or off the actual smart switch.

    Hope this helps

    Sent from my SM-G955F using Tapatalk
     
  18. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Oh I see. So the task runs fine manually, but just not automatically when you flip the switch? :)
     
  19. 9ixxer Lee

    9ixxer Lee New Member

    Joined:
    Jul 25, 2015
    Messages:
    16
    Likes Received:
    0
    yup

    Sent from my SM-G955F using Tapatalk
     
  20. joaomgcd

    joaomgcd Administrator Staff Member

    Joined:
    Feb 3, 2015
    Messages:
    9,476
    Likes Received:
    797
    Can you please try removing the Old Value and New Value values from the context and see if that works?
     

Share This Page